summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew S. Turnbull <sparky@bluefang-logic.com>2021-01-26 22:32:22 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-01 15:02:43 +0200
commit5fc24844a2084d667c64b473a1fc403f24cfec83 (patch)
tree2a8040ba9cd0c664ac93f6e3f05a424ebc71560a /x11-libs
parentgnome-extra/cinnamon-desktop: Fix meson script shebangs (diff)
downloadgentoo-5fc24844a2084d667c64b473a1fc403f24cfec83.tar.gz
gentoo-5fc24844a2084d667c64b473a1fc403f24cfec83.tar.bz2
gentoo-5fc24844a2084d667c64b473a1fc403f24cfec83.zip
x11-libs/xapps: Fix meson script shebangs
Also, xdg_environment_reset is handled by EAPI-7. Bug: https://bugs.gentoo.org/766935 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xapps/xapps-1.8.9.ebuild5
-rw-r--r--x11-libs/xapps/xapps-2.0.6.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/x11-libs/xapps/xapps-1.8.9.ebuild b/x11-libs/xapps/xapps-1.8.9.ebuild
index da3eb4f5ac9f..6245bcf0201c 100644
--- a/x11-libs/xapps/xapps-1.8.9.ebuild
+++ b/x11-libs/xapps/xapps-1.8.9.ebuild
@@ -45,9 +45,12 @@ BDEPEND="
"
src_prepare() {
- xdg_environment_reset
vala_src_prepare
default
+
+ # Fix meson helpers
+ python_setup
+ python_fix_shebang meson-scripts schemas
}
src_configure() {
diff --git a/x11-libs/xapps/xapps-2.0.6.ebuild b/x11-libs/xapps/xapps-2.0.6.ebuild
index 0dc60ed63845..3059ed0a95c1 100644
--- a/x11-libs/xapps/xapps-2.0.6.ebuild
+++ b/x11-libs/xapps/xapps-2.0.6.ebuild
@@ -47,12 +47,15 @@ BDEPEND="
"
src_prepare() {
- xdg_environment_reset
vala_src_prepare
default
# don't install distro specific tools
sed -i "/subdir('scripts')/d" meson.build || die
+
+ # Fix meson helpers
+ python_setup
+ python_fix_shebang meson-scripts
}
src_configure() {