summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2019-10-30 14:03:19 +0100
committerMatt Turner <mattst88@gentoo.org>2020-02-02 18:36:22 -0800
commit66d950c109ef07428aaf8a1d1d234ee7ba42df55 (patch)
tree32257d290bef80aa18a67dfa7710cccf3cd7adb9 /x11-libs
parentx11-plugins/wmMatrix: fix build with -fno-common (diff)
downloadgentoo-66d950c109ef07428aaf8a1d1d234ee7ba42df55.tar.gz
gentoo-66d950c109ef07428aaf8a1d1d234ee7ba42df55.tar.bz2
gentoo-66d950c109ef07428aaf8a1d1d234ee7ba42df55.zip
x11-libs/pango: Version bump to 1.44.7
From Polynomial-C's overlay. Closes: https://bugs.gentoo.org/698922 Closes: https://github.com/gentoo/gentoo/pull/13498 Signed-off-by: David Heidelberg <david@ixit.cz> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/files/pango-1.44.7-tests-test-break.c-Only-test-Thai-breaks-with-libtha.patch35
-rw-r--r--x11-libs/pango/pango-1.44.7.ebuild81
3 files changed, 117 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index b156ec8c167b..43cbd6530e5c 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -1,2 +1,3 @@
DIST pango-1.42.4-patchset.tar.xz 6040 BLAKE2B ec3f1a6a4de30e0864e7f0bf0950cb7a7b4bada8c3db496a8e5b1e770f221ae72b43167178445ea9cd0d6b88e51d2af49e7fdf27b2e792997fe7c37e55d429c1 SHA512 b7654c3493931e3c6d3cbd40ee49c5cbebaf403954bae75dea80e9f03e12dd5082548aff6a9e778821b8f935e227a7efaad4c1b980fa108e7258042221cadfc1
DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b835828d027963a53cce3f204ee1ea0042ec492e209de9136f05ca131ccda959bc477d4f6e9c72e5f620ddf4235f26 SHA512 993e97f647eba0c5ed90bcfcb8228bf67fa3f20b1f4331e4e40a30788d7c3ac55eee1209471bf21df125cb8fc6121acc8062a9da2f8a7d6cbe8e9ad13a9320dc
+DIST pango-1.44.7.tar.xz 521384 BLAKE2B 9917efc1bcc9115331149d77eb9b15373d4331ed6a8e5542a97fbbbb480eb0557736d4f1817c0fd56262f442e4b3c2c68607baacdd38b1684def1af58a583bfb SHA512 6e0a3d5cd32c209fd71a2ce5f705a60db318c2133bcca07360a047a73892f642a1661c1f0fb90353fc43e75336dfc22909bf4969f1bd03324c9689344af08350
diff --git a/x11-libs/pango/files/pango-1.44.7-tests-test-break.c-Only-test-Thai-breaks-with-libtha.patch b/x11-libs/pango/files/pango-1.44.7-tests-test-break.c-Only-test-Thai-breaks-with-libtha.patch
new file mode 100644
index 000000000000..181d84587e13
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.44.7-tests-test-break.c-Only-test-Thai-breaks-with-libtha.patch
@@ -0,0 +1,35 @@
+https://gitlab.gnome.org/GNOME/pango/merge_requests/161
+
+From b73284747ac937e31dc9191f84ed6e24284c88ee Mon Sep 17 00:00:00 2001
+From: Chun-wei Fan <fanchunwei@src.gnome.org>
+Date: Mon, 25 Nov 2019 14:58:32 +0800
+Subject: [PATCH] tests/test-break.c: Only test Thai breaks with libthai
+ available
+
+The four.break test data file involves the Thai language, meaning that
+this test will fail unless we have libthai. Skip this test unless
+libthai is found.
+---
+ tests/test-break.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/tests/test-break.c b/tests/test-break.c
+index 8549b678..47fa3009 100644
+--- a/tests/test-break.c
++++ b/tests/test-break.c
+@@ -305,6 +305,12 @@ main (int argc, char *argv[])
+ if (!strstr (name, "break"))
+ continue;
+
++#ifndef HAVE_LIBTHAI
++ /* four.break involves Thai, so only test it when we have libthai */
++ if (strstr (name, "four.break"))
++ continue;
++#endif
++
+ path = g_strdup_printf ("/break/%s", name);
+ g_test_add_data_func_full (path, g_test_build_filename (G_TEST_DIST, "breaks", name, NULL),
+ test_break, g_free);
+--
+2.24.1
+
diff --git a/x11-libs/pango/pango-1.44.7.ebuild b/x11-libs/pango/pango-1.44.7.ebuild
new file mode 100644
index 000000000000..cbaa8b80c48a
--- /dev/null
+++ b/x11-libs/pango/pango-1.44.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils meson multilib-minimal toolchain-funcs xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# X USE flag is simply a stub until all revdeps have been adjusted to use X(+)
+IUSE="gtk-doc +introspection test +X"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/fribidi-0.19.7[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.59.2:2[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.12.92:1.0=[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0:=[glib(+),truetype(+),${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X,${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.20
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tests-test-break.c-Only-test-Thai-breaks-with-libtha.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ tc-export CXX
+
+ local emesonargs=(
+ -Dgtk_doc="$(multilib_native_usex gtk-doc true false)"
+ -Dintrospection="$(multilib_native_usex introspection true false)"
+ -Dinstall-tests=false
+ )
+ meson_src_configure
+}
+
+muiltilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}