summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-08-31 22:35:13 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-08-31 22:35:13 +0100
commit6f1459cb45e9d8ae5ae2ec5055ea8b0b193de8d5 (patch)
treeea2fc0bae0dc8d931e124b2fb226a772b0095d51 /x11-libs
parentsys-cluster/kube-scheduler: remove 1.18.19 (diff)
downloadgentoo-6f1459cb45e9d8ae5ae2ec5055ea8b0b193de8d5.tar.gz
gentoo-6f1459cb45e9d8ae5ae2ec5055ea8b0b193de8d5.tar.bz2
gentoo-6f1459cb45e9d8ae5ae2ec5055ea8b0b193de8d5.zip
x11-libs/libfakeXinerama: New package for xpra
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfakeXinerama/Manifest1
-rw-r--r--x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild30
-rw-r--r--x11-libs/libfakeXinerama/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/libfakeXinerama/Manifest b/x11-libs/libfakeXinerama/Manifest
new file mode 100644
index 000000000000..99c08a1f1285
--- /dev/null
+++ b/x11-libs/libfakeXinerama/Manifest
@@ -0,0 +1 @@
+DIST libfakeXinerama-0.1.0.tar.bz2 3191 BLAKE2B 3f3572a64c6aafc71df9db7dc0c88125f4eb53dc7ae5dd22a704964664f3e21423241892b92be3591dffeca264660b1dd0880989e8088091d0731105ffec224b SHA512 6b2cd7a3ebd751d869b8afd1c129412f7bc8e8098d7f27a1781078c33f5fa644374524d3e7f5a7b9cf0297edb848d6ff7ec8f29d312e2af0c88d248c751ef907
diff --git a/x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild b/x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild
new file mode 100644
index 000000000000..d1a8f77f32ee
--- /dev/null
+++ b/x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Fake library to override default libXinerama and expose custom screen dimensions"
+HOMEPAGE="https://github.com/Xpra-org/libfakeXinerama"
+SRC_URI="https://xpra.org/src/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+
+src_compile() {
+ libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -c ${PN#lib}.c || die
+ libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -Wl,-z,defs ${PN#lib}.lo \
+ -o ${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" -version-number 1:0:0 || die
+}
+
+src_install() {
+ dolib.so .libs/${PN}$(get_libname)*
+ dodoc README.TXT
+}
diff --git a/x11-libs/libfakeXinerama/metadata.xml b/x11-libs/libfakeXinerama/metadata.xml
new file mode 100644
index 000000000000..d1e8c601f846
--- /dev/null
+++ b/x11-libs/libfakeXinerama/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Xpra-org/libfakeXinerama</remote-id>
+ </upstream>
+</pkgmetadata>