summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-08-13 23:41:45 -0700
committerHanno <hanno@gentoo.org>2016-08-13 23:41:45 -0700
commit6f6b9d7cc242afe6b4c048f0eebc88e725ece45b (patch)
tree4f21770710499f39325b93c6011d29fa677ac5d5 /x11-libs
parentsys-devel/llvm: update the live ebuild (diff)
downloadgentoo-6f6b9d7cc242afe6b4c048f0eebc88e725ece45b.tar.gz
gentoo-6f6b9d7cc242afe6b4c048f0eebc88e725ece45b.tar.bz2
gentoo-6f6b9d7cc242afe6b4c048f0eebc88e725ece45b.zip
x11-libs/libfm-extra: Version bump, fix ABI version
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm-extra/Manifest1
-rw-r--r--x11-libs/libfm-extra/libfm-extra-1.2.4.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/x11-libs/libfm-extra/Manifest b/x11-libs/libfm-extra/Manifest
index 7361d3d75317..0a620143c73c 100644
--- a/x11-libs/libfm-extra/Manifest
+++ b/x11-libs/libfm-extra/Manifest
@@ -1 +1,2 @@
DIST libfm-1.2.3.tar.xz 898256 SHA256 c692f1624a4cbc8d1dd55f3b3f3369fbf5d26f63a916e2c295230b2344e1fbf9 SHA512 f4c214daffc47f05ba31c65203ab0542a03f5a246ea4bb62b6b365ac3fa120a1a51e37b00f8a43afe56875eb69f9be327ac724dafb6fc2de13aa77deea23f443 WHIRLPOOL ae5354c5ef5154ebce8a9124b47e0a645171d50d4034fd1e6000ff084acc15261398029c58b067b9027d4ba68d36d8addf91a28678c91a3fbd9ce0806e9b6046
+DIST libfm-1.2.4.tar.gz 1259686 SHA256 30474f25e4fbf78f50c7e2493cc4eca5970243089393d25a80f3d79b478a2ce7 SHA512 7196ae4af99ef41d77e1113dea62e35244b0be57c8cd7fcef2e0559daa5564ddfb163293225708c1697068e6a41d9842f96991145c34c41a7f510f38345d2f9c WHIRLPOOL d42d7ee5d7fefd1c100a0b7f741a20a2d98e84bbea57cfe3b3f197e7731538bda51c4c916a88e185ce937bab88fcda7b511d3da81660f6f36f32ef389f480f1b
diff --git a/x11-libs/libfm-extra/libfm-extra-1.2.4.ebuild b/x11-libs/libfm-extra/libfm-extra-1.2.4.ebuild
new file mode 100644
index 000000000000..340973eaef43
--- /dev/null
+++ b/x11-libs/libfm-extra/libfm-extra-1.2.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools fdo-mime
+
+MY_PV=${PV/_/}
+MY_PN="libfm"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="A library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="https://github.com/lxde/libfm/archive/1.2.4.tar.gz -> ${MY_P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+SLOT="0/4.4.0" #copy ABI_VERSION because it seems upstream change it randomly
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext
+ !!<=x11-libs/libfm-1.2.3"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -ie '/^SUBDIR.*=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
+ sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
+ configure.ac || die "sed failed"
+
+ #disable unused translations. Bug #356029
+ for trans in app-chooser ask-rename exec-file file-prop preferred-apps \
+ progress;do
+ echo "data/ui/"${trans}.ui >> po/POTFILES.in
+ done
+ #Remove -Werror for automake-1.12. Bug #421101
+ sed -i "s:-Werror::" configure.ac || die
+
+ # subslot sanity check
+ local sub_slot=${SLOT#*/}
+ local libfm_major_abi=$(sed -rne '/ABI_VERSION/s:.*=::p' src/Makefile.am | tr ':' '.')
+
+ if [[ ${sub_slot} != ${libfm_major_abi} ]]; then
+ eerror "Ebuild sub-slot (${sub_slot}) does not match ABI_VERSION(${libfm_major_abi})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${libfm_major_abi}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ eautoreconf
+ rm -r autom4te.cache || die
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}/etc" --disable-dependency-tracking \
+ --disable-static --with-extra-only
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+ # Sometimes a directory is created instead of a symlink. No idea why...
+ # It is wrong anyway. We expect a libfm-1.0 directory and then a libfm
+ # symlink to it.
+ if [[ -h ${D}/usr/include/${MY_PN} || -d ${D}/usr/include/${MY_PN} ]]; then
+ rm -r "${D}"/usr/include/${MY_PN}
+ fi
+}
+
+pkg_preinst() {
+ # Resolve the symlink mess. Bug #439570
+ [[ -d "${ROOT}"/usr/include/${MY_PN} ]] && \
+ rm -rf "${ROOT}"/usr/include/${MY_PN}
+ if [[ -d "${D}"/usr/include/${MY_PN}-1.0 ]]; then
+ cd "${D}"/usr/include
+ ln -s --force ${MY_PN}-1.0 ${MY_PN}
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}