summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-23 22:12:24 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-23 22:12:24 +0200
commit6fb0e2e2f7abb01fd13d208ca69d1f17066b002c (patch)
tree308e165f52af6549cb77e5d500a7c0ebbd40b5d5 /x11-libs
parentnet-libs/rest: update EAPI 6 -> 8 (diff)
downloadgentoo-6fb0e2e2f7abb01fd13d208ca69d1f17066b002c.tar.gz
gentoo-6fb0e2e2f7abb01fd13d208ca69d1f17066b002c.tar.bz2
gentoo-6fb0e2e2f7abb01fd13d208ca69d1f17066b002c.zip
x11-libs/gtksourceview: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.24.11-r1.ebuild (renamed from x11-libs/gtksourceview/gtksourceview-3.24.11.ebuild)21
1 files changed, 8 insertions, 13 deletions
diff --git a/x11-libs/gtksourceview/gtksourceview-3.24.11.ebuild b/x11-libs/gtksourceview/gtksourceview-3.24.11-r1.ebuild
index 7db2b001cb01..c2c1e31bf88e 100644
--- a/x11-libs/gtksourceview/gtksourceview-3.24.11.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-3.24.11-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-VALA_MIN_API_VERSION="0.24"
-VALA_USE_DEPEND="vapigen"
+EAPI=8
+VALA_USE_DEPEND="vapigen"
inherit gnome2 vala virtualx
DESCRIPTION="A text widget implementing syntax highlighting and other features"
@@ -12,12 +11,10 @@ HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="3.0/3"
-
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
IUSE="glade +introspection +vala"
REQUIRED_USE="vala? ( introspection )"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-
RDEPEND="
>=dev-libs/glib-2.48:2
>=dev-libs/libxml2-2.6:2
@@ -25,7 +22,8 @@ RDEPEND="
glade? ( >=dev-util/glade-3.9:3.10 )
introspection? ( >=dev-libs/gobject-introspection-1.42:= )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/glib-utils
>=dev-util/gtk-doc-am-1.25
>=sys-devel/gettext-0.19.4
@@ -33,12 +31,9 @@ DEPEND="${RDEPEND}
vala? ( $(vala_depend) )
"
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
src_configure() {
+ use vala && vala_setup
+
gnome2_src_configure \
$(use_enable glade glade-catalog) \
$(use_enable introspection) \