summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-02 21:15:30 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-02 21:47:02 -0400
commit7171e7af48dab6d7ae3a466a72475921b3b06f55 (patch)
tree064f11654280a3b87b91841d094044fb09f648d5 /x11-libs
parentsys-cluster/kronosnet: Stabilize 1.19-r1 ppc64, #907726 (diff)
downloadgentoo-7171e7af48dab6d7ae3a466a72475921b3b06f55.tar.gz
gentoo-7171e7af48dab6d7ae3a466a72475921b3b06f55.tar.bz2
gentoo-7171e7af48dab6d7ae3a466a72475921b3b06f55.zip
x11-libs/xtrans: Version bump to 1.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xtrans/Manifest1
-rw-r--r--x11-libs/xtrans/xtrans-1.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-libs/xtrans/Manifest b/x11-libs/xtrans/Manifest
index c048e9593404..73b283154b84 100644
--- a/x11-libs/xtrans/Manifest
+++ b/x11-libs/xtrans/Manifest
@@ -1 +1,2 @@
DIST xtrans-1.4.0.tar.bz2 185371 BLAKE2B 15e5ff810f8df94fa6a050dab00158646003ecc7b200e199eb713d8bd6e7ca8df1769490ebc3d8b8920915bb5f2ede698f01a1a120ca09acfc85f225c4d618f8 SHA512 4fea89a3455c0e13321cbefa43340016dbb59bdd0dbdb5b796c1a6d2a6b1fd63cf1327b769ab426286b9c54b32ec764a50cd2b46228e4e43b841bda6b94de214
+DIST xtrans-1.5.0.tar.xz 170388 BLAKE2B a07dc501a36f4a6d7d9c407c36c5fcaa9555eeec3066d91fa8531118ac04bc55a1fbdce6370782aa8a18e1f26b14e3ad644e1e98ae3a353234e3ecae71fe065b SHA512 e8091f11d4ad2b14e01de3eac56bdf2267ea26687ce66e3056374d0d02e049480c0b27c482f8828a0efd086f1e4c485108ca4dce3f83d66c1896effa3b38b228
diff --git a/x11-libs/xtrans/xtrans-1.5.0.ebuild b/x11-libs/xtrans/xtrans-1.5.0.ebuild
new file mode 100644
index 000000000000..05aaabe65c58
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_PACKAGE_NAME="lib${PN}"
+# this package just installs some .c and .h files, no libraries
+XORG_DOC=doc
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xtrans library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}