summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:34:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:34:52 +0100
commit78accd40b217d6839d401135a6182f2dc7fff710 (patch)
tree76545a32167b2b53e10b932856f02b0dc9d86f9c /x11-libs
parentmedia-video/simplescreenrecorder: Synced live ebuild. (diff)
downloadgentoo-78accd40b217d6839d401135a6182f2dc7fff710.tar.gz
gentoo-78accd40b217d6839d401135a6182f2dc7fff710.tar.bz2
gentoo-78accd40b217d6839d401135a6182f2dc7fff710.zip
x11-libs/libxkbcommon: Bump to version 0.8.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index bdefbc0a3842..aca7247a977b 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,4 @@
DIST libxkbcommon-0.6.0.tar.xz 608700 BLAKE2B c82ce8dd9971e53161630d044b48fc5d11011d828ac20f5918a985a3c38c05e85ee3864610238d77a78b7295d7f95a074cec829767e31d1629d23cc8811ea539 SHA512 b70ff4b3b85f03cc2875622ccfa60ba6f1b86a07be90df8be73b867771dd08a85740df95fe8dfef2bacf4356a6dfc9c51523ec6ce60d197184860577b39586c4
DIST libxkbcommon-0.7.1.tar.xz 622384 BLAKE2B f45c0a8f882504210e1fd7d4535643cb4245b3fdfedc03a73fd1c149ee32149431d1ae3f0a54a27a28dc05a70c6701c314f07f252da9363e5b8124f1b9f1c18d SHA512 9f209214d5d7f9334cabb2cd7e0d9b9b0392c1fae06b60e92a03398875399fe48754b543389f78b8b06dd28a86dfd440720e534bae309ca8ef882eb874dce4e1
DIST libxkbcommon-0.7.2.tar.xz 630276 BLAKE2B df4f29be0583f40008b48077dc5d4c0de7bdf66fc5df6e6df723f59623cbc681578f40fa5240fbef62ea785aed049805b65bfce82eb6497a4eaa27660103a10e SHA512 4a06f9d719393a34689fdd74b0cce80af20e26cc5bd6e1b34fff4093a4f8f103704bdc54f0245b62903cdd7529cd8d59864924b9f4ddab314d152804da4da649
+DIST libxkbcommon-0.8.0.tar.xz 643456 BLAKE2B 37f8e8ccff63354dc37ec26091a7da28f5a1f05ca0656b03716cdcdbf3172344d600b3b2b646da309ea3e4f04bde1b1279c96b07c493266ec6489935177efbbc SHA512 ad64baa03685b72e1047f9fdfc95661acf5bace59280a95d3defaca73c91fb77c31ecde00b430726e3521ff90cf8dd93ecbc816c18be0971cb616e00b81cf163
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild
new file mode 100644
index 000000000000..0a4987e6ce5a
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}