summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:20:22 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:20:22 +0100
commit979a9bd8a6f13aa110f158e8fa8185d82f79cfb6 (patch)
treed07cade993f2c9323f39423c0991a8c9a2203a23 /x11-libs
parentsys-libs/pinktrace: disable static libs (diff)
downloadgentoo-979a9bd8a6f13aa110f158e8fa8185d82f79cfb6.tar.gz
gentoo-979a9bd8a6f13aa110f158e8fa8185d82f79cfb6.tar.bz2
gentoo-979a9bd8a6f13aa110f158e8fa8185d82f79cfb6.zip
x11-libs/libast: disable static libs
Closes: https://bugs.gentoo.org/726142 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libast/libast-0.7-r2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/x11-libs/libast/libast-0.7-r2.ebuild b/x11-libs/libast/libast-0.7-r2.ebuild
index 1d705a9e46f5..15f7036f2454 100644
--- a/x11-libs/libast/libast-0.7-r2.ebuild
+++ b/x11-libs/libast/libast-0.7-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -22,22 +22,19 @@ RDEPEND="
media-libs/freetype
imlib? ( media-libs/imlib2 )
pcre? ( dev-libs/libpcre )"
-
DEPEND="${RDEPEND}"
-DOCS=( README DESIGN ChangeLog )
-
-src_prepare() {
- default
- local myregexp="posix"
- use pcre && myregexp="pcre"
+src_configure() {
econf \
$(use_with imlib) \
$(use_enable cpu_flags_x86_mmx mmx) \
- --with-regexp="${myregexp}"
+ --with-regexp=$(usex pcre pcre posix) \
+ --disable-static
}
src_install() {
default
- emake DESTDIR="${D}" install
+ dodoc DESIGN
+
+ find "${ED}" -name '*.la' -delete || die
}