summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-12-15 11:20:40 -0800
committerMatt Turner <mattst88@gentoo.org>2016-12-15 11:20:54 -0800
commita2143aa470a5a91853398ea8b6cabcb64b9145d6 (patch)
tree3d3fe6c7c2ebdf4118b116ffcc7775105c7d19ea /x11-libs
parentdev-util/cmake: Disabled Qt5Autogen check (breaks for unknown reason). (diff)
downloadgentoo-a2143aa470a5a91853398ea8b6cabcb64b9145d6.tar.gz
gentoo-a2143aa470a5a91853398ea8b6cabcb64b9145d6.tar.bz2
gentoo-a2143aa470a5a91853398ea8b6cabcb64b9145d6.zip
x11-libs/libXpm: Version bump to 3.5.12.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXpm/Manifest1
-rw-r--r--x11-libs/libXpm/libXpm-3.5.12.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/libXpm/Manifest b/x11-libs/libXpm/Manifest
index 17ba87f367a8..98f78982380d 100644
--- a/x11-libs/libXpm/Manifest
+++ b/x11-libs/libXpm/Manifest
@@ -1,2 +1,3 @@
DIST libXpm-3.5.10.tar.bz2 431310 SHA256 a6db7e234750e7d60330017972e31d8e1f29f0a8c1391e4ac82f6102d919a735 SHA512 27ddf49ec13e77ee89cc3dfcf95631576a941e9fab18bfa1bbe2d45e8979548793f8723ffa4d97db7fdb4909883f9efa2c7d6e2996696f82940fdd7518e2c49d WHIRLPOOL ac4871d7b3e5fe90cdd0b6f31fb00fa26dd35985027947dd116a20b5738ed290804b84d70ebcc52577235045cb1272dbe0b04512630c47b8b26b679008a78fa4
DIST libXpm-3.5.11.tar.bz2 443496 SHA256 c5bdafa51d1ae30086fac01ab83be8d47fe117b238d3437f8e965434090e041c SHA512 c089056108d4598f6c4603d6440d9ef6216e87c5cf1e30d143b0e7abc9c5d6f40050c747a57a27d751bc80786ded0390d97cbe221be628241c881d21a3ce6024 WHIRLPOOL d2b60fcfe2b591a452074e2bb9ba7f22ce705f86716a547bf9a8b75454c6e5f06848086880f14459440ca4106f1b3247f84de2fb705686082c34a5194e38d484
+DIST libXpm-3.5.12.tar.bz2 430736 SHA256 fd6a6de3da48de8d1bb738ab6be4ad67f7cb0986c39bd3f7d51dd24f7854bdec SHA512 a5707d5f758d577414101b0723af334fc8ac223e5b9f869994765735e1cbd8dafed48ea2851ebc479fecaf84381bfd5fbef842ec971a487f7fa9e77d54d3a17e WHIRLPOOL 4e44eb629b7c862528b8a07b6ce752570951fc6dac93fb093b2b08c5313646699373e125df174c88524ddc6726e3b0af02230b4bbecb269ff08a600f59286705
diff --git a/x11-libs/libXpm/libXpm-3.5.12.ebuild b/x11-libs/libXpm/libXpm-3.5.12.ebuild
new file mode 100644
index 000000000000..7090b9a9e996
--- /dev/null
+++ b/x11-libs/libXpm/libXpm-3.5.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xpm library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ # the gettext configure check and code in sxpm are incorrect; they assume
+ # gettext being in libintl, whereas Solaris has gettext by default
+ # resulting in libintl not being added to LIBS
+ [[ ${CHOST} == *-solaris* ]] && export ac_cv_search_gettext=-lintl
+ xorg-2_src_configure
+}