summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-20 20:57:30 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-22 16:15:58 -0500
commitb9ab8d410b201f244f075e2168a7829db487f693 (patch)
treeef381a5c6ac898292905d2af637cd365318581ba /x11-libs
parentx11-misc/compose-tables: Add split package (diff)
downloadgentoo-b9ab8d410b201f244f075e2168a7829db487f693.tar.gz
gentoo-b9ab8d410b201f244f075e2168a7829db487f693.tar.bz2
gentoo-b9ab8d410b201f244f075e2168a7829db487f693.zip
x11-libs/libX11: Version bump to 1.7.0
Thanks to Cedric Sodhi for figuring out how to split the compose-tables out into a separate package. Closes: https://bugs.gentoo.org/749576 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index 4fcb6e82b0b1..a9c7f15d3c64 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1 +1,2 @@
DIST libX11-1.6.12.tar.bz2 2376498 BLAKE2B a2c6c76d5d4a15073f7837e6a72ecd8b7711dfcec48c54da538a6100a4afa01334a9456376633f1a2365717e03231c6b777c5683e462d10564065dc2437da39a SHA512 79df7d61d9009b0dd3b65f67a62189aa0a43799c01026b3d2d534092596a0b67f246af5e398a89eb1ccc61a27335f81be8262b8a39768a76f62d862cd7415a47
+DIST libX11-1.7.0.tar.bz2 2409144 BLAKE2B 1eb6aa8f2fe50ddb2f6d324429b3d9cecfb48833c3f52f22ae8e32846be614c8db63c57d25e2b1c46612b6b333ff61ceab8ac0b605b117bcea1224f918af8e6d SHA512 f661ca90350fd8a94f054b00f12f5122cea068ebff706acfd399462236c189a296a2358d17d16166635101cf56cc19303dd407873a159932d093c9f33556f9fb
diff --git a/x11-libs/libX11/libX11-1.7.0.ebuild b/x11-libs/libX11/libX11-1.7.0.ebuild
new file mode 100644
index 000000000000..b074ab686443
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ !<x11-base/xorg-proto-2019.2
+ x11-misc/compose-tables"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable ipv6)
+ --without-fop
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -Rf "${D}/usr/share/X11/locale"
+}