summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-03-21 10:40:01 +0200
committerSam James <sam@gentoo.org>2021-03-27 16:42:30 +0000
commitbfb49fa661909c57e5c9db87fe30413d7c8c5e1b (patch)
tree78967178e9baefa9e10652ab77d255eace295425 /x11-libs
parentmedia-gfx/xpaint: fix passing LDFLAGS (diff)
downloadgentoo-bfb49fa661909c57e5c9db87fe30413d7c8c5e1b.tar.gz
gentoo-bfb49fa661909c57e5c9db87fe30413d7c8c5e1b.tar.bz2
gentoo-bfb49fa661909c57e5c9db87fe30413d7c8c5e1b.zip
x11-libs/libXaw3dXft: update to version 1.6.2h
Dependency of media-gfx/xpaint-3.1.3 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXaw3dXft/Manifest1
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-libs/libXaw3dXft/Manifest b/x11-libs/libXaw3dXft/Manifest
index 75ee54ff0259..3c2383e71d22 100644
--- a/x11-libs/libXaw3dXft/Manifest
+++ b/x11-libs/libXaw3dXft/Manifest
@@ -1 +1,2 @@
DIST libXaw3dXft-1.6.2d.tar.bz2 584670 BLAKE2B cde040659a90edb50ac5aa374e8ec04442479ae1c06fe3d5b1387bd3e02c1a0b40ff286ad40f0ae7841544d1244648e34905570e5827dc0efe60a62da3261c9a SHA512 ac434b7f055d20ceb0bd17851d8ba69976ec562a60cb8012a259045e52c038278f0a8b25b52a61befab3aa169b74fd919278c671f1b6e282efb404e089772740
+DIST libXaw3dXft-1.6.2h.tar.bz2 593436 BLAKE2B e0e5c3a3e5b4564d58bb059ad7eb594d1a46cc37e0e21799ea11892d206a57f3f11a46d7413310d2a43738f03e001f5dc6f8c3b86bbe806fbc651661e9f720db SHA512 bc9b6de80379bdc82c7f5cd46ac78a422282b018eed979ef5548d0382f43e53619a6ebaf40c6b9ae264d597536022dc1daf023c1d1a04e948d4b4658bc6479ca
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
new file mode 100644
index 000000000000..3c771bc204fd
--- /dev/null
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="Xaw3dXft library"
+HOMEPAGE="https://sourceforge.net/projects/sf-xpaint"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(usex xpm "--enable-multiplane-bitmaps" "")
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+ xorg-3_src_configure
+}