summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-11 11:57:08 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-11 12:20:19 -0400
commitc352cc1ed35a5c2b8866d7a64e3372b72c27eb84 (patch)
tree0bfe94275646e7a9920ad682cc377b74d14b7c65 /x11-libs
parentdev-util/glade: Version bump to 3.40.0 (diff)
downloadgentoo-c352cc1ed35a5c2b8866d7a64e3372b72c27eb84.tar.gz
gentoo-c352cc1ed35a5c2b8866d7a64e3372b72c27eb84.tar.bz2
gentoo-c352cc1ed35a5c2b8866d7a64e3372b72c27eb84.zip
x11-libs/pango: Version bump to 1.50.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.50.9.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 63caf519d4f8..321a0980b6e5 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -2,3 +2,4 @@ DIST pango-1.42.4-patchset.tar.xz 6040 BLAKE2B ec3f1a6a4de30e0864e7f0bf0950cb7a7
DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b835828d027963a53cce3f204ee1ea0042ec492e209de9136f05ca131ccda959bc477d4f6e9c72e5f620ddf4235f26 SHA512 993e97f647eba0c5ed90bcfcb8228bf67fa3f20b1f4331e4e40a30788d7c3ac55eee1209471bf21df125cb8fc6121acc8062a9da2f8a7d6cbe8e9ad13a9320dc
DIST pango-1.50.7.tar.xz 4294752 BLAKE2B 049b7c09f2ec35ca229eadcd146513d2b292fac8c2296a1635f32c1e21a2ff14979c4ce4a88f966d2d85dad55e356f089c09e00062d06373f7d0760871333046 SHA512 4d754ed753fc34074c2a8751459406af7eb1eccb227c6158287f7e2921614d918cae47d078d4a2b4c098b641e40274e81bf1ec6b6a1b147efd550626665767d3
DIST pango-1.50.8.tar.xz 4298760 BLAKE2B 76531815c5b472823b62e0c7a44d4a6c8cf38d587527cceff46e9e7ad302c53abd5827ed4242db2f754761928632b986517ca2814a1ddb9501b2832bbadb3116 SHA512 81821e5837d5fb78a07ac8f8e360de9a9bf9b2418a3e0654f80ee3dce7f98325ea2483cc7c1d1db4a662886a1244530515d83480f4c3bc0510788a9bbbae2f91
+DIST pango-1.50.9.tar.xz 4262208 BLAKE2B 13495015a7b22fb33d6c06e2fd2f325f30a80ee88a9ae7306aea477bc0551762ef20b3ebb4d8c4a45e791f25e675264a1d1973b703e131b4caab42369e4bd293 SHA512 f108274174c0ff5eabedddd8a3ed23ba124c85b72dbc9c003fee388fe8775deb0946ad3dfd7c96e70a30268cbd390e29c4c184ff30300d99add70ba0ead59b3e
diff --git a/x11-libs/pango/pango-1.50.9.ebuild b/x11-libs/pango/pango-1.50.9.ebuild
new file mode 100644
index 000000000000..84a85e7a5a68
--- /dev/null
+++ b/x11-libs/pango/pango-1.50.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+IUSE="debug +introspection sysprof test X"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.6.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.13.0:1.0=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( media-fonts/cantarell )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.50.8-harfbuzz-4.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}