summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-11 14:06:16 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-11 19:38:55 +0300
commitc5d4930bc0c388ad4d29fb0c72eaeb837c54f975 (patch)
tree8868600cd2d08267da59e18f4b9c51ac5481c85f /x11-libs
parentmedia-libs/mesa: Enable asserts only with USE=debug (diff)
downloadgentoo-c5d4930bc0c388ad4d29fb0c72eaeb837c54f975.tar.gz
gentoo-c5d4930bc0c388ad4d29fb0c72eaeb837c54f975.tar.bz2
gentoo-c5d4930bc0c388ad4d29fb0c72eaeb837c54f975.zip
x11-libs/vte: bump to 0.54.0
Closes: https://bugs.gentoo.org/654834 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/Manifest2
-rw-r--r--x11-libs/vte/vte-0.54.0.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index cffcf243ce9f..c322719a48f5 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -2,3 +2,5 @@ DIST vte-0.28.2.tar.xz 962340 BLAKE2B 1e4b5977962265be77917ccfc9118ed93232c03d7a
DIST vte-0.36.5.tar.xz 1017504 BLAKE2B a7a94b389660f9bbf7aa8033e4a5e2cc96c39458e43960ad2ce785f2fbe1597c7156d090aab220e909ae31f8731d0d961686dce08aef0f270581c01de4bf19b0 SHA512 43f9211381238ca6cb7f49c8a9dd8f48f702e9968e038fa26ee69228c1fc86061d5dbfabb2c27f677280e89ae9080f20594f3c27481246e3f91dd5f3ea0354f6
DIST vte-0.48.4-command-notify.patch.xz 5500 BLAKE2B 88b655403d2bef034604a283b173fece305af35f51b20f9d4811b33265b5a6eb83441e0b978539de501d118a8431c4a9a9a69a111a03c45adc87763b15b09fd2 SHA512 b8ba202aedb5d821962a7cdc89e6ef8ac8a3480dd7681bf8ce708ce511598f3335ba153750d40cb06e9a2c5bab5888b3daef9096458c2889d94028feaa394575
DIST vte-0.48.4.tar.xz 1008296 BLAKE2B 9f946d6909d38896ec80db2a02666d809155997b27109724fb318d28200220f1514fb23e4cdc90263a756914b5db442c947578c8854a535cb960a06f7bc03a77 SHA512 4b75bd881e58b5043bc44e391ef3a826a2c25d0f1bb5ffb890367e11a60b1bcbce091575ede6972a89ae043b39c51897f91fca1faf6872664d602e503d8020fc
+DIST vte-0.53.91-command-notify.patch.xz 3336 BLAKE2B f1eb7ce8ae5a975028474e0d31b14a35722cc32578dcb68905ec92b0ca048c8e1b7c903c7195248435db58a6cc60afce7376b38a3606b8ec88c8f28a7c127f71 SHA512 aab84dd050b5b9f59e9dc5e17a41a27f4650aecbd3fcb847b63b9bb79c84d3e544212e6cf6b4693424a44e14f8576c4f54eaea70a211dc0c40ae5887ca6114e8
+DIST vte-0.54.0.tar.xz 1082032 BLAKE2B 6349a7d7d04df26be3fca3c414aecd00e8a25b912af39446a412cd86c8b0165977933945786e840e2ed39d0f2fa8d51f2fc8052f00f56e47b4f1d62ffa00b968 SHA512 69dd0caae4eacc179f84eccf98625a31140286beca4244a8f06420bd36ac62dcaddf9e9d8b114549ca97927e94b562df3e7daa9fad971484f05ebdd1c0f7b787
diff --git a/x11-libs/vte/vte-0.54.0.ebuild b/x11-libs/vte/vte-0.54.0.ebuild
new file mode 100644
index 000000000000..e2b8d002f121
--- /dev/null
+++ b/x11-libs/vte/vte-0.54.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.91"
+IUSE="+crypt debug glade +introspection vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~leio/distfiles/${PN}-0.53.91-command-notify.patch.xz )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/libpcre2-10.21
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses:0=
+ sys-libs/zlib
+
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${RDEPEND}
+ !x11-libs/vte:2.90[glade]
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # First half of http://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/vte291-command-notify-scroll-speed.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.53.91-command-notify.patch # Manually updated to post-0.53.0 VteTerminalPrivate rename; recheck with Fedora patch for 0.54.0+ once they get it
+ fi
+
+ use vala && vala_src_prepare
+
+ # build fails because of -Werror with gcc-5.x
+ sed -e 's#-Werror=format=2#-Wformat=2#' -i configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ gnome2_src_configure \
+ --disable-static \
+ --with-gtk=3.0 \
+ --with-iconv \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_with crypt gnutls) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_install() {
+ gnome2_src_install
+ mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}