summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-04-05 23:17:00 -0400
committerMatt Turner <mattst88@gentoo.org>2024-04-05 23:17:17 -0400
commitcd1c49390dde43b0f8fc93e0cd9eb8228292c6bd (patch)
treed70dd49f6ea5953061304429e1bd698b8cb20348 /x11-libs
parentx11-misc/compose-tables: Version bump to 1.8.9 (diff)
downloadgentoo-cd1c49390dde43b0f8fc93e0cd9eb8228292c6bd.tar.gz
gentoo-cd1c49390dde43b0f8fc93e0cd9eb8228292c6bd.tar.bz2
gentoo-cd1c49390dde43b0f8fc93e0cd9eb8228292c6bd.zip
x11-libs/libX11: Version bump to 1.8.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/Manifest1
-rw-r--r--x11-libs/libX11/libX11-1.8.9.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/libX11/Manifest b/x11-libs/libX11/Manifest
index 323078f4bdf6..8c3df55e4480 100644
--- a/x11-libs/libX11/Manifest
+++ b/x11-libs/libX11/Manifest
@@ -1,2 +1,3 @@
DIST libX11-1.8.7.tar.xz 1859256 BLAKE2B 335d8af91c13aba11255c266c4687a7f66b021207a92485d723b4107601bbabb6a0e5535241a3bcff4ac9a99142730d2b3d2e2eaff86b507fee5b35a2590d792 SHA512 d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6
DIST libX11-1.8.8.tar.xz 1872808 BLAKE2B d180932c65c565d113ae768bb0035aa98ff7dd265de9a7907f54f994b1520d7fc67699032450afc5d8f9427247f73dcf71259ff6a3f734d71f6e8b6181c6891b SHA512 4e7ce8f2d88b9475f960ea1d5730ece8953509e0c057cf2d0a2f5fa6a36e6577b0dcd7f16ac91b8fdd804aabec6d7e8f3067a3a8667bd2e41d72dd68ab70ef82
+DIST libX11-1.8.9.tar.xz 1811900 BLAKE2B 8858157ac490d65e19500bfbb2ab773a3a30041f8a757ff22fff8fb0124044b8bb826f6dff4115230c757a175b61a3f7d596d976d98be760085749878d64f871 SHA512 737af91818537295ac86be601b1e3d7e37d150716ec549580913b7cc9a44fee7a6ce9dbc3d46167eed91f23fe857c4dd355ed8f8440fe5fbbf8e9ebe47091b96
diff --git a/x11-libs/libX11/libX11-1.8.9.ebuild b/x11-libs/libX11/libX11-1.8.9.ebuild
new file mode 100644
index 000000000000..8b0055d7b7dc
--- /dev/null
+++ b/x11-libs/libX11/libX11-1.8.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX=xz
+inherit toolchain-funcs xorg-3
+
+# Note: please bump this with x11-misc/compose-tables
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+
+ !<xfce-base/xfce4-settings-4.16.3
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans
+"
+BDEPEND="test? ( dev-lang/perl )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ --enable-ipv6
+ --without-fop
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+ CPP="$(tc-getPROG CPP cpp)"
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+ rm -rf "${ED}"/usr/share/X11/locale || die
+}