summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-08-08 12:23:48 -0700
committerMatt Turner <mattst88@gentoo.org>2018-08-08 12:25:20 -0700
commite6e87073ed0c27048fdb2c73ccb055d098c6f041 (patch)
tree9710fa14a4c7b741d0f2df3c9808dd30acd15b6b /x11-libs
parentdev-libs/wayland-protocols: Version bump to 1.16 (diff)
downloadgentoo-e6e87073ed0c27048fdb2c73ccb055d098c6f041.tar.gz
gentoo-e6e87073ed0c27048fdb2c73ccb055d098c6f041.tar.bz2
gentoo-e6e87073ed0c27048fdb2c73ccb055d098c6f041.zip
x11-libs/libxkbcommon: Version bump to 0.8.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index b469af146577..e3f923ef7595 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1 +1,2 @@
DIST libxkbcommon-0.8.0.tar.xz 643456 BLAKE2B 37f8e8ccff63354dc37ec26091a7da28f5a1f05ca0656b03716cdcdbf3172344d600b3b2b646da309ea3e4f04bde1b1279c96b07c493266ec6489935177efbbc SHA512 ad64baa03685b72e1047f9fdfc95661acf5bace59280a95d3defaca73c91fb77c31ecde00b430726e3521ff90cf8dd93ecbc816c18be0971cb616e00b81cf163
+DIST libxkbcommon-0.8.2.tar.xz 644040 BLAKE2B c323384308d9730924d6f1cb7ad55fdb3d1a37289f648b981c54dc5997c67c857d33f8ad872fc7646b462ebc97252dca30efe2a2e12d1f1f08a8a1604a5de23f SHA512 b714240ec6120bbe44b5da7a4f89b1c2f24cfd6e5ebbe81e5290d135c8f2e5a68f89ac256b73430a446167345f8db309b35dcf74f3d3840e20897cd91eccc172
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild
new file mode 100644
index 000000000000..ceb492d0aaff
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}