summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-11 08:14:18 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-11 08:38:00 +0200
commitf0920386a09b0c19fe1e91fd0a9fae6ff85f08fc (patch)
treeb291a53dbd890b9b63cda41775df0549cc7e4808 /x11-libs
parentnet-libs/gnome-online-accounts: version bump 3.24.2-r1 → 3.24.3 (diff)
downloadgentoo-f0920386a09b0c19fe1e91fd0a9fae6ff85f08fc.tar.gz
gentoo-f0920386a09b0c19fe1e91fd0a9fae6ff85f08fc.tar.bz2
gentoo-f0920386a09b0c19fe1e91fd0a9fae6ff85f08fc.zip
x11-libs/gtksourceview: version bump 3.24.3 → 3.24.4
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtksourceview/Manifest1
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.24.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index 26950d075089..be511509febb 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -1,3 +1,4 @@
DIST gtksourceview-2.10.5.tar.bz2 1253321 SHA256 c585773743b1df8a04b1be7f7d90eecdf22681490d6810be54c81a7ae152191e SHA512 6f64acef6196bfc5953e0b148d7e460d366073b5e21367c01b01fc4d1c86ffe8aca71ecd77cf0814e47d8fc3085495f25bbbdc69e746987b02fd02fcda64886d WHIRLPOOL 4bd2589d4e06bb5e5c4dc8c55af25c52fd2c2c318a1240d7a430c8cb442cc785b7048f0116d9df714f93c6c1cb87628459239a80ae317d8eb73d27e4c021281a
DIST gtksourceview-3.22.2.tar.xz 1596384 SHA256 6ce84231dd0931cc747708434ca2f344c65a092dd6e1a800283fe0748773af5e SHA512 1d51a975471172835cd9af64828ba93eb1b45e26fae91b1778c5963a8578404bbbdf1fe7f2c92953dff436bf2dac2d9e01a5188216d2a60a705e4635f0c91b81 WHIRLPOOL 76f333a55d868f6e56bdf8ead44b541c78083a5a64d5b19ae2423a9b22cb8cf17e2fe063dd1a569baab192597c34dde42c6f104c27c13d40b364a81f71e8a183
DIST gtksourceview-3.24.3.tar.xz 1625584 SHA256 3eed05486a6420c3e2fdda0bbb19a0d905ed09ebf442302a026ab7e574204cbd SHA512 354a06502d55d7b237d5cbec5a35102225ae3d7e80e53d1ba42e506fc9c75470c4548b4ab8e9e6b2813d732617a2f13b978194240556b8d810066c94ec13de44 WHIRLPOOL 100e811aa7cc3194f4c63c84af2d4a45e413320c1b5fe3e09a5b506fd3cc910dcb9e1a71f8f4c647918d6c95c10d27b2bfe633b9dfac35d791caf55c50182858
+DIST gtksourceview-3.24.4.tar.xz 1619860 SHA256 207fb1958087d89393521eafac05f6dd67448ef6edb43ec2c708a79f3b1aa793 SHA512 fef2008dccae6bca859f99b7171851b84f30e7b4cdb00500972039bf111ab5901498820c91926374a7b446491330c55f7179e8522b90279d0169371981bc90fd WHIRLPOOL a0d1d6e9bf0e73545b489010abd823c236a24416c5374ff2ee1344536b2cc2a655b0a544cde96fe21f4734e9e398b9d806aac233d7e7f3f1696f2b317d8cd9ca
diff --git a/x11-libs/gtksourceview/gtksourceview-3.24.4.ebuild b/x11-libs/gtksourceview/gtksourceview-3.24.4.ebuild
new file mode 100644
index 000000000000..1e25a7583c48
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.24.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.48:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ dev-util/itstool
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}