summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-06 18:35:30 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-06 18:37:30 +0200
commitffce128c5f201555cec8fbd8b7b00dfdc1673f63 (patch)
treefbd0ca19eec8c6b3d7544b97aa4799387d26426c /x11-libs
parentapp-eselect/eselect-lua: do not PDEPEND on Lua implementations (diff)
downloadgentoo-ffce128c5f201555cec8fbd8b7b00dfdc1673f63.tar.gz
gentoo-ffce128c5f201555cec8fbd8b7b00dfdc1673f63.tar.bz2
gentoo-ffce128c5f201555cec8fbd8b7b00dfdc1673f63.zip
x11-libs/gtk+: bump to 3.24.24
Closes: https://bugs.gentoo.org/755881 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest1
-rw-r--r--x11-libs/gtk+/gtk+-3.24.24.ebuild246
-rw-r--r--x11-libs/gtk+/metadata.xml2
3 files changed, 249 insertions, 0 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index 0cc898badf9d..c937b50318db 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -2,3 +2,4 @@ DIST gtk+-2.24.32-patchset-r1.tar.xz 13364 BLAKE2B 15e5429b11cc4ccef1bf44105c790
DIST gtk+-2.24.32.tar.xz 12620860 BLAKE2B 03f4c0a8be98473f62bc8c86859937969c4169960a5f93d37ff6dcde00413215fa6c7125b15781bf50d67b40aa0056cb71b83fb50acb2c3467b5deb3c8d938f0 SHA512 8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696
DIST gtk+-3.24.20.tar.xz 22726768 BLAKE2B 75daa850275d55758503fa98055ca4deb9adca172e0f38c39ca4d5e7f8179398ca8753a759b0d3afc1ad1712ac6e3aa2cc1bce29e2a8fff4198a7f2d70002b11 SHA512 bda8eeacf721afcff4565756fe45857cbf8b053494d1d747ca9b97c899e9fe21fddef6871ecd5ec9a7a0f87b0a3ede2f9d6b5e5712de10a845100d82464a4556
DIST gtk+-3.24.22.tar.xz 21349784 BLAKE2B 03dac82b3928a77beab1b4fcfcb9fdeb5e458fae13f7ff5459c2c65c7acdd6b255e62cbeaace02ec19ab4a41ff3ba2003dc004bcbaa4ee8206986e35fd7d1084 SHA512 ac653438a0a818885f2aa46a131b1ab0038a57b438406724a674313d8bf4325b1d2e87e4e8c77a92d0cfa8f8d6eaac46ba6890830290e9a9e598c978144861a2
+DIST gtk+-3.24.24.tar.xz 21341240 BLAKE2B a48024c008061b7e9c6ce8fe787e6c2f734923f5f17f818d2284afa6ea9ac080a55d358afcd0b73f3a124d57959c7a07a90c479b784fc881a3c9a0b9e354454f SHA512 f4e22d7c78d7c641ac7c3beeb3181000b72b025c65074bab6bd51b9a86ec4f6a2e25f06ad7671a908be421c064f4c26e2185febb424f310a2530561aebde8520
diff --git a/x11-libs/gtk+/gtk+-3.24.24.ebuild b/x11-libs/gtk+/gtk+-3.24.24.ebuild
new file mode 100644
index 000000000000..7f419c9caecc
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.24.24.ebuild
@@ -0,0 +1,246 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+
+inherit flag-o-matic gnome2 multilib virtualx multilib-minimal
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="https://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+IUSE="aqua broadway cloudprint colord cups examples gtk-doc +introspection +sysprof test vim-syntax wayland +X xinerama"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ xinerama? ( X )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Upstream wants us to do their job:
+# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
+RESTRICT="test"
+
+# FIXME: introspection data is built against system installation of gtk+:3,
+# bug #????
+COMMON_DEPEND="
+ >=dev-libs/atk-2.32.0[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-0.19.7[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.57.2:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=media-libs/libepoxy-1.4[X(+)?,${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.41.0[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-0.9:=
+ x11-misc/shared-mime-info
+
+ cloudprint? (
+ >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-2.0[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+ wayland? (
+ >=dev-libs/wayland-1.14.91[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.17
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=app-accessibility/at-spi2-atk-2.15.1[${MULTILIB_USEDEP}]
+ media-libs/mesa[X(+),${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.5[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-libs/gobject-introspection-common
+ >=dev-util/gdbus-codegen-2.48
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.20
+ gtk-doc? ( >=dev-util/gtk-doc-1.20
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.7[${MULTILIB_USEDEP}]
+ virtual/pkgconfig
+ sysprof? ( >=dev-util/sysprof-capture-3.33.2:3 )
+ X? ( x11-base/xorg-proto )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )
+"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+ !<gnome-base/gail-1000
+ !<x11-libs/vte-0.31.0:2.90
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg[${MULTILIB_USEDEP}]
+ >=x11-themes/adwaita-icon-theme-3.14
+ vim-syntax? ( app-vim/gtk-syntax )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0$(get_exeext)
+)
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ if ! use test ; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS testsuite Makefile.{am,in}
+
+ # the tests dir needs to be build now because since commit
+ # 7ff3c6df80185e165e3bf6aa31bd014d1f8bf224 tests/gtkgears.o needs to be there
+ # strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
+ strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
+ fi
+
+ # gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
+ eapply "${FILESDIR}"/${PN}-3.24.8-update-icon-cache.patch
+
+ # Fix broken autotools logic
+ eapply "${FILESDIR}"/${PN}-3.22.20-libcloudproviders-automagic.patch
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable aqua quartz-backend)
+ $(use_enable broadway broadway-backend)
+ $(use_enable cloudprint)
+ $(use_enable colord)
+ $(use_enable cups cups auto)
+ $(multilib_native_use_enable gtk-doc)
+ $(multilib_native_use_enable introspection)
+ # TODO: sysprof-capture:3 doesn't support multilib; enable multilib support once gtk moves to sysprof-capture:4
+ $(multilib_native_use_enable sysprof profiler)
+ $(use_enable wayland wayland-backend)
+ $(use_enable X x11-backend)
+ $(use_enable X xcomposite)
+ $(use_enable X xdamage)
+ $(use_enable X xfixes)
+ $(use_enable X xkb)
+ $(use_enable X xrandr)
+ $(use_enable xinerama)
+ # cloudprovider is not packaged in Gentoo yet
+ --disable-cloudproviders
+ --disable-papi
+ --enable-man
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ # TODO: Is this still the case?
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
+ )
+
+ if use wayland; then
+ myconf+=(
+ # Include wayland immodule into gtk itself, to avoid problems like
+ # https://gitlab.gnome.org/GNOME/gnome-shell/issues/109 from a
+ # user overridden GTK_IM_MODULE envvar
+ --with-included-immodules=wayland
+ )
+ fi;
+
+ ECONF_SOURCE=${S} gnome2_src_configure "${myconf[@]}"
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in gdk gtk libgail-util; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+ # Skip README.{in,commits,win32} that would get installed by default
+ DOCS=( AUTHORS ChangeLog NEWS README )
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make immodules.cache belongs to gtk+ alone
+ local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_query_immodules_gtk3 \
+ || die "Update immodules cache failed (for ${ABI})"
+ }
+ multilib_parallel_foreach_abi multilib_pkg_postinst
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+ fi
+}
diff --git a/x11-libs/gtk+/metadata.xml b/x11-libs/gtk+/metadata.xml
index 7fe0a6b99d41..ec37e738f2ce 100644
--- a/x11-libs/gtk+/metadata.xml
+++ b/x11-libs/gtk+/metadata.xml
@@ -16,6 +16,8 @@
<flag name="cloudprint">Enable printing via Google Cloud Print.</flag>
<flag name="colord">Use <pkg>x11-misc/colord</pkg> for color management
in printing</flag>
+ <flag name="sysprof">Enable profiling data capture support using
+ <pkg>dev-util/sysprof-capture</pkg></flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:gtk:gtk%2B</remote-id>