summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-02-22 18:16:59 +1100
committerMichael Palimaka <kensington@gentoo.org>2019-02-22 18:17:25 +1100
commitbadf43edfdcefa72122897f8e57e2075f52f946d (patch)
tree3b7a3676def71b29bb6821462c5022cc626e77a1 /x11-misc/albert/albert-0.16.1.ebuild
parentapp-text/ansifilter: remove 2.10 and 2.12 (diff)
downloadgentoo-badf43edfdcefa72122897f8e57e2075f52f946d.tar.gz
gentoo-badf43edfdcefa72122897f8e57e2075f52f946d.tar.bz2
gentoo-badf43edfdcefa72122897f8e57e2075f52f946d.zip
x11-misc/albert: version bump 0.16.1
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'x11-misc/albert/albert-0.16.1.ebuild')
-rw-r--r--x11-misc/albert/albert-0.16.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/albert/albert-0.16.1.ebuild b/x11-misc/albert/albert-0.16.1.ebuild
new file mode 100644
index 000000000000..c04869d05ca7
--- /dev/null
+++ b/x11-misc/albert/albert-0.16.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLUGINS_HASH="029bd8ccb58c4452bd82ab42be8739f1639e42d4"
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://albertlauncher.github.io/"
+# plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
+SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-cpp/muParser
+ dev-qt/qtcharts:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DEBUG=$(usex debug)
+ -DBUILD_PYTHON=OFF #plugin directory is empty causing build failure
+ -DBUILD_VIRTUALBOX=OFF #plugin needs virtualbox installed to build, untested
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}