summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-10 21:14:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-10 21:14:52 +0200
commit7bc772bcad27cc44f1033399514e83c6a1294cbc (patch)
tree5a6f47ee0994e1dff5b40a2f4dbde646604c0eec /x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.3-r1.ebuild
parentmedia-gfx/darktable: version bump (diff)
downloadgentoo-7bc772bcad27cc44f1033399514e83c6a1294cbc.tar.gz
gentoo-7bc772bcad27cc44f1033399514e83c6a1294cbc.tar.bz2
gentoo-7bc772bcad27cc44f1033399514e83c6a1294cbc.zip
x11-misc/appmenu-gtk-module: Fix typo in startup script
Closes: https://bugs.gentoo.org/736613 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.3-r1.ebuild')
-rw-r--r--x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.3-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.3-r1.ebuild b/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..ce784a6457b5
--- /dev/null
+++ b/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2-utils systemd
+
+DESCRIPTION="Application menu module for GTK"
+HOMEPAGE="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
+SRC_URI="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/570a2d1a65e77d42cb19e5972d0d1b84/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib[dbus]
+ >=x11-libs/gtk+-2.24.0:2
+ >=x11-libs/gtk+-3.22.0:3
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland
+"
+
+src_prepare() {
+ cmake_src_prepare
+ sed -i -e "/^pkg_check_modules(SYSTEMD/d" data/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGSETTINGS_COMPILE=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_VCM=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/${PN} 85-${PN}
+
+ systemd_dounit "${BUILD_DIR}"/data/appmenu-gtk-module.service
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}