summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-03-06 10:28:54 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-06 10:32:58 +0100
commitcb46b5af8325fc41d8f0e5186de2ee912aeb4018 (patch)
tree05f20628d0b56752b34738478d1ed3755d9560ae /x11-misc/autorandr
parentnet-mail/dovecot: Fix typo in lua plugin (diff)
downloadgentoo-cb46b5af8325fc41d8f0e5186de2ee912aeb4018.tar.gz
gentoo-cb46b5af8325fc41d8f0e5186de2ee912aeb4018.tar.bz2
gentoo-cb46b5af8325fc41d8f0e5186de2ee912aeb4018.zip
x11-misc/autorandr: add 1.15
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc/autorandr')
-rw-r--r--x11-misc/autorandr/Manifest1
-rw-r--r--x11-misc/autorandr/autorandr-1.15.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/autorandr/Manifest b/x11-misc/autorandr/Manifest
index 6f4c8baceb83..a12c572c47a7 100644
--- a/x11-misc/autorandr/Manifest
+++ b/x11-misc/autorandr/Manifest
@@ -1,2 +1,3 @@
DIST autorandr-1.13.3.tar.gz 47630 BLAKE2B fb53316af4d3fa399f278be874e95d06cbd188bebf1e22793ca30ad4f9a8817674390c7d02d501f4a35a0a6f23b16202e97f2a6559727e67e908d21121de8a56 SHA512 6c3f99da52a029a8f1717020ebafbd7afb58d97651776a6620f47e299584704ab65c37be5e9497cca3c53d6268ebde11481f32967ec289adf606a73e587e874f
DIST autorandr-1.14.tar.gz 49234 BLAKE2B 3ff149d30b023bc54d83c4be1f81f67204d20d3e6a7a43e15009c1c4f1180fa920789ce84ae56f13946a9cec1f72bc7adb27be3c58ca8532235d0457b1f5aa92 SHA512 dc1ee4c28b06dde4a721fe564734e7a79c1c843986f7c84307ea60f19c2237ba53d1bcd2202e377363e7e0a5bf5dea95bea4490b3fa5ec5fa6738114646a502d
+DIST autorandr-1.15.tar.gz 49352 BLAKE2B b7200eb7a77230076f1a9f8b1a21be883ae363cc41cff7f1191e034359cc8ebb52e9dd19dd5f2e415a34b9a3a89fda3d0d43a946b2f3401de0d279fb9d5ba1a2 SHA512 2837348b755f5c4b30ad2b68e191e1969a467401cf32dda495dd19867e391f8b8b4a9c0b4958ef33f75c71aace46686995e27bab805e1e40cc4a1af44e9f0405
diff --git a/x11-misc/autorandr/autorandr-1.15.ebuild b/x11-misc/autorandr/autorandr-1.15.ebuild
new file mode 100644
index 000000000000..0011c189d5ca
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.15.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+# desktop-file-util: uses desktop-file-edit in Makefile
+BDEPEND="
+ dev-util/desktop-file-utils
+ virtual/pkgconfig
+"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}
+
+pkg_postrm() {
+ if use udev; then
+ udev_reload
+ fi
+}