summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbkeys
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbkeys')
-rw-r--r--x11-misc/bbkeys/Manifest2
-rw-r--r--x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild31
-rw-r--r--x11-misc/bbkeys/bbkeys-0.9.1.ebuild25
-rw-r--r--x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch59
-rw-r--r--x11-misc/bbkeys/metadata.xml13
5 files changed, 130 insertions, 0 deletions
diff --git a/x11-misc/bbkeys/Manifest b/x11-misc/bbkeys/Manifest
new file mode 100644
index 000000000000..a6e69b1e37f9
--- /dev/null
+++ b/x11-misc/bbkeys/Manifest
@@ -0,0 +1,2 @@
+DIST bbkeys-0.9.0.tar.gz 199146 SHA256 1ebf372e35b31e7bd63c9a28d2434cfc44588db08b653df64a396d2821dd9ff0
+DIST bbkeys-0.9.1.tar.gz 226941 SHA256 4381994b998a0b41e3b27d532bdb2a859fefaca260705022eeec8c1c02e99680
diff --git a/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild b/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..b8fe4ba8b533
--- /dev/null
+++ b/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Use keyboard shortcuts in the blackbox wm"
+HOMEPAGE="http://bbkeys.sourceforge.net"
+SRC_URI="mirror://sourceforge/bbkeys/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-wm/blackbox-0.70.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ rm -rf "${D}/usr/share/doc"
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}
diff --git a/x11-misc/bbkeys/bbkeys-0.9.1.ebuild b/x11-misc/bbkeys/bbkeys-0.9.1.ebuild
new file mode 100644
index 000000000000..ccd84533b98a
--- /dev/null
+++ b/x11-misc/bbkeys/bbkeys-0.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Use keyboard shortcuts in the blackbox wm"
+HOMEPAGE="http://bbkeys.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-wm/blackbox-0.70.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm -rf "${D}"/usr/share/doc
+ dodoc AUTHORS BUGS ChangeLog NEWS README || die
+
+ echo PRELINK_PATH_MASK=/usr/bin/bbkeys > "${T}"/99bbkeys
+ doenvd "${T}"/99bbkeys || die
+}
diff --git a/x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch b/x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch
new file mode 100644
index 000000000000..58b536ff38e2
--- /dev/null
+++ b/x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch
@@ -0,0 +1,59 @@
+diff -Naupr bbkeys-0.9.0.orig/src/actions.cc bbkeys-0.9.0/src/actions.cc
+--- bbkeys-0.9.0.orig/src/actions.cc 2005-02-20 22:03:43.000000000 +0100
++++ bbkeys-0.9.0/src/actions.cc 2008-02-24 09:26:30.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include "actions.hh"
+
+ #include <iostream>
+-#include <string>
++#include <cstring>
++#include <cstdlib>
+ #include <sstream>
+
+ Action::Action(enum ActionType type, Display * display, KeyCode keycode,
+diff -Naupr bbkeys-0.9.0.orig/src/Config.cpp bbkeys-0.9.0/src/Config.cpp
+--- bbkeys-0.9.0.orig/src/Config.cpp 2004-09-03 03:08:00.000000000 +0200
++++ bbkeys-0.9.0/src/Config.cpp 2008-02-24 09:29:55.000000000 +0100
+@@ -24,7 +24,7 @@
+
+
+ #include "Config.h"
+-#include <string>
++#include <cstring>
+
+ #include <iostream>
+ using std::cout;
+diff -Naupr bbkeys-0.9.0.orig/src/KeyClient.cpp bbkeys-0.9.0/src/KeyClient.cpp
+--- bbkeys-0.9.0.orig/src/KeyClient.cpp 2004-09-26 04:27:46.000000000 +0200
++++ bbkeys-0.9.0/src/KeyClient.cpp 2008-02-24 09:26:14.000000000 +0100
+@@ -58,6 +58,7 @@ extern "C" {
+ #include <iostream>
+ #include <algorithm>
+ #include <vector>
++#include <cstring>
+
+ //--------------------------------------------------------
+ // Constructor/Destructor
+diff -Naupr bbkeys-0.9.0.orig/src/main.cpp bbkeys-0.9.0/src/main.cpp
+--- bbkeys-0.9.0.orig/src/main.cpp 2004-09-16 02:53:51.000000000 +0200
++++ bbkeys-0.9.0/src/main.cpp 2008-02-24 09:31:38.000000000 +0100
+@@ -27,6 +27,8 @@
+
+ #include "main.h"
+
++#include <cstring>
++
+ //--------------------------------------------------------
+ // parseOptions
+ //--------------------------------------------------------
+diff -Naupr bbkeys-0.9.0.orig/src/Netclient.cpp bbkeys-0.9.0/src/Netclient.cpp
+--- bbkeys-0.9.0.orig/src/Netclient.cpp 2004-09-26 04:27:46.000000000 +0200
++++ bbkeys-0.9.0/src/Netclient.cpp 2008-02-24 09:30:41.000000000 +0100
+@@ -25,6 +25,7 @@
+ // Methods, ideas, implementations taken from Openbox's XAtom class *sigh*
+
+ #include "Netclient.h"
++#include <cstring>
+
+ Netclient::Netclient (const bt::Display &display)
+ : bt::EWMH(display), _display(display)
diff --git a/x11-misc/bbkeys/metadata.xml b/x11-misc/bbkeys/metadata.xml
new file mode 100644
index 000000000000..82f8fca0a209
--- /dev/null
+++ b/x11-misc/bbkeys/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A keygrabber for Blackbox.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbkeys</remote-id>
+ </upstream>
+</pkgmetadata>