summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbsload
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbsload')
-rw-r--r--x11-misc/bbsload/Manifest1
-rw-r--r--x11-misc/bbsload/bbsload-0.2.9.ebuild29
-rw-r--r--x11-misc/bbsload/files/bbsload-0.2.8-as-needed.patch23
-rw-r--r--x11-misc/bbsload/files/bbsload-0.2.8-gcc43.patch14
-rw-r--r--x11-misc/bbsload/metadata.xml11
5 files changed, 78 insertions, 0 deletions
diff --git a/x11-misc/bbsload/Manifest b/x11-misc/bbsload/Manifest
new file mode 100644
index 000000000000..c4cd54834e8a
--- /dev/null
+++ b/x11-misc/bbsload/Manifest
@@ -0,0 +1 @@
+DIST bbsload-0.2.9.tar.gz 127556 SHA256 9a7f626cd66fa6d04a6aee83b31652ebe2604b1b8848ff5737a3a753a98acd82 SHA512 73bdf9da03bea0253ebec6aaf2cbd1e287bf97c2e9669c05fe878b24e3d30bfb6ad9c7b0be358f89ead646f023b2f0fc0ea1cc1b153713b91c005fbfbf8f4591 WHIRLPOOL a44b672e22fbd373911570a3dc3a949512a7ee77f2e8f71b3859ccc8215116e368c5ec81453e248b750091165e0524cc14c76a556c639972784195f7eaa9d95d
diff --git a/x11-misc/bbsload/bbsload-0.2.9.ebuild b/x11-misc/bbsload/bbsload-0.2.9.ebuild
new file mode 100644
index 000000000000..0caf4016715c
--- /dev/null
+++ b/x11-misc/bbsload/bbsload-0.2.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox load monitor"
+HOMEPAGE="http://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="media-fonts/font-adobe-100dpi"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.8-as-needed.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbsload
+}
diff --git a/x11-misc/bbsload/files/bbsload-0.2.8-as-needed.patch b/x11-misc/bbsload/files/bbsload-0.2.8-as-needed.patch
new file mode 100644
index 000000000000..fd3aa0a42de3
--- /dev/null
+++ b/x11-misc/bbsload/files/bbsload-0.2.8-as-needed.patch
@@ -0,0 +1,23 @@
+diff -NrU5 bbsload-0.2.8.orig/configure.in bbsload-0.2.8/configure.in
+--- bbsload-0.2.8.orig/configure.in 2008-12-18 00:44:23.000000000 +0100
++++ bbsload-0.2.8/configure.in 2008-12-18 00:46:33.000000000 +0100
+@@ -87,16 +87,16 @@
+ AC_PATH_X
+ AC_PATH_XTRA
+
+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
++LIBS="$X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
++AC_CHECK_LIB(X11, XOpenDisplay, LIBS="$LIBS -lX11",
+ AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++LIBS="$LIBS $X_EXTRA_LIBS"
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(malloc.h)
+
diff --git a/x11-misc/bbsload/files/bbsload-0.2.8-gcc43.patch b/x11-misc/bbsload/files/bbsload-0.2.8-gcc43.patch
new file mode 100644
index 000000000000..e506ca26d808
--- /dev/null
+++ b/x11-misc/bbsload/files/bbsload-0.2.8-gcc43.patch
@@ -0,0 +1,14 @@
+diff -aur bbsload-0.2.8.old/resource.hh bbsload-0.2.8/resource.hh
+--- bbsload-0.2.8.old/resource.hh 2008-11-25 18:09:55.000000000 +0100
++++ bbsload-0.2.8/resource.hh 2008-11-25 18:12:49.000000000 +0100
+@@ -121,8 +121,8 @@
+ {
+
+ public:
+- Resource::Resource(ToolWindow *);
+- Resource::~Resource(void);
++ Resource(ToolWindow *);
++ ~Resource(void);
+
+ struct FRAME frame;
+ struct LABEL label;
diff --git a/x11-misc/bbsload/metadata.xml b/x11-misc/bbsload/metadata.xml
new file mode 100644
index 000000000000..5da1df511b3b
--- /dev/null
+++ b/x11-misc/bbsload/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Load monitor for Blackbox.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>