summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-07-09 16:43:29 +0200
committerPacho Ramos <pacho@gentoo.org>2022-07-09 16:43:29 +0200
commit12c224ecede8c225a12ac185ffc987576f7031ac (patch)
tree672b6dfb8dd8e972091b74810f6bba934a89a9bb /x11-misc/bumblebee/bumblebee-9999.ebuild
parentkde-frameworks/kross: 5.96.0 version bump (diff)
downloadgentoo-12c224ecede8c225a12ac185ffc987576f7031ac.tar.gz
gentoo-12c224ecede8c225a12ac185ffc987576f7031ac.tar.bz2
gentoo-12c224ecede8c225a12ac185ffc987576f7031ac.zip
x11-misc/bumblebee: Call udev_reload
Closes: https://bugs.gentoo.org/852782 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-misc/bumblebee/bumblebee-9999.ebuild')
-rw-r--r--x11-misc/bumblebee/bumblebee-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-misc/bumblebee/bumblebee-9999.ebuild b/x11-misc/bumblebee/bumblebee-9999.ebuild
index 4c2cecf46ce5..bd63a8594628 100644
--- a/x11-misc/bumblebee/bumblebee-9999.ebuild
+++ b/x11-misc/bumblebee/bumblebee-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools readme.gentoo-r1 systemd
+inherit autotools readme.gentoo-r1 systemd udev
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -91,3 +91,11 @@ src_install() {
You may need to setup your /etc/bumblebee/bumblebee.conf"
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}