summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2018-06-08 15:14:43 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2018-07-16 00:57:50 -0400
commitcfe1c73d0f40b355e00e733b3889f0ed33476499 (patch)
treeb0a9388ad5a63d490ce9506904ceb029f107cd11 /x11-misc/bumblebee
parentgames-strategy/freeorion: Backport fix for detecting SDL2 incl dir (diff)
downloadgentoo-cfe1c73d0f40b355e00e733b3889f0ed33476499.tar.gz
gentoo-cfe1c73d0f40b355e00e733b3889f0ed33476499.tar.bz2
gentoo-cfe1c73d0f40b355e00e733b3889f0ed33476499.zip
x11-misc/bumblebee: Bump to latest development commit
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-misc/bumblebee')
-rw-r--r--x11-misc/bumblebee/Manifest1
-rw-r--r--x11-misc/bumblebee/bumblebee-3.2.1_p20170130.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/x11-misc/bumblebee/Manifest b/x11-misc/bumblebee/Manifest
index 92f4952549ad..898009991f01 100644
--- a/x11-misc/bumblebee/Manifest
+++ b/x11-misc/bumblebee/Manifest
@@ -1,2 +1,3 @@
DIST bumblebee-3.2.1.tar.gz 143110 BLAKE2B 537fe96e061f229c4c1e7748aef89e4eec040536d7a3161b449a34752c19078d3b4da6703f1c11268b4bb0e6590f94168bab5917fceac0eb73825b3c233548f0 SHA512 6f016f75d199577215ff00c059e196829e9d3efeb0fb6eebe6c3fad6176e330332e1ef25875a22ac9892895683d95899ea44f1ec1f85d31300ad83cb1fe0310a
DIST bumblebee-3.2.1_p20170123.tar.gz 63376 BLAKE2B 986cc1ff39d937547268b07c98f8881810586c58a40f454cb3839aea4e5f116b27b8947acc7b1e05f3cca7a3f717f963ae3ad9f379473b40b898e6fcfedff5e6 SHA512 398101927211a8d09f19d519fd0537c94b942bd7fc11d10d394a3a520f2afa6abe174db78b60bb134caf78ffda4cdd50d0ef424134acd07ff4ce93998881e31b
+DIST bumblebee-3.2.1_p20170130.tar.gz 63428 BLAKE2B 33a2fbbd6e6cbc6cd026b87714d06e54d8803cc75e997cc1bd1aa1d1263c3fe9602f822b92c67fa7e76632bb19daaae11e591b88d087889a970d374f6316e847 SHA512 b457e8ce197782bd1b1fabd3c0c67e4ec26cdb90a3715bbe7a8e1550cdde19134151567cfa0c73d800c30e5d303b30bc1261d5f3cbceaa64d559416e4d541070
diff --git a/x11-misc/bumblebee/bumblebee-3.2.1_p20170130.ebuild b/x11-misc/bumblebee/bumblebee-3.2.1_p20170130.ebuild
new file mode 100644
index 000000000000..cb8c3ee88762
--- /dev/null
+++ b/x11-misc/bumblebee/bumblebee-3.2.1_p20170130.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib readme.gentoo-r1 systemd user
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Bumblebee-Project/Bumblebee.git"
+ EGIT_BRANCH="develop"
+ KEYWORDS=""
+else
+ COMMIT="d469a32fc0dfef5b3725c7a5331be2d04b870594"
+ SRC_URI="https://github.com/Bumblebee-Project/Bumblebee/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S="${WORKDIR}/Bumblebee-${COMMIT}"
+fi
+
+DESCRIPTION="Service providing elegant and stable means of managing Optimus graphics chipsets"
+HOMEPAGE="https://bumblebee-project.org https://github.com/Bumblebee-Project/Bumblebee"
+
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="+bbswitch video_cards_nouveau video_cards_nvidia"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libbsd
+ sys-apps/kmod
+ x11-libs/libX11
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/opengl
+ x11-base/xorg-drivers[video_cards_nvidia?,video_cards_nouveau?]
+ bbswitch? ( sys-power/bbswitch )
+"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+PDEPEND="
+ || (
+ x11-misc/primus
+ x11-misc/virtualgl
+ )
+"
+
+REQUIRED_USE="|| ( video_cards_nouveau video_cards_nvidia )"
+
+pkg_setup() {
+ enewgroup bumblebee
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use video_cards_nvidia ; then
+ # Get paths to GL libs for all ABIs
+ local i nvlib=""
+ for i in $(get_all_libdirs) ; do
+ nvlib="${nvlib}:/usr/${i}/opengl/nvidia/lib"
+ done
+
+ local nvpref="/usr/$(get_libdir)/opengl/nvidia"
+ local xorgpref="/usr/$(get_libdir)/xorg/modules"
+ ECONF_PARAMS="CONF_DRIVER=nvidia CONF_DRIVER_MODULE_NVIDIA=nvidia \
+ CONF_LDPATH_NVIDIA=${nvlib#:} \
+ CONF_MODPATH_NVIDIA=${nvpref}/lib,${nvpref}/extensions,${xorgpref}/drivers,${xorgpref}"
+ fi
+
+ econf \
+ ${ECONF_PARAMS}
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newenvd "${FILESDIR}"/${PN}.envd 99${PN}
+ systemd_dounit scripts/systemd/bumblebeed.service
+
+ local DOC_CONTENTS="In order to use Bumblebee, add your user to 'bumblebee' group.
+ You may need to setup your /etc/bumblebee/bumblebee.conf"
+ readme.gentoo_create_doc
+}