summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-08 07:00:04 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-08 17:16:05 +0200
commit5a257242158d5067022f92c7e4b5d22a511b3552 (patch)
treeb14c70660533d254725e89459098b8eba35bbfac /x11-misc/cbatticon/cbatticon-1.6.10.ebuild
parentnet-analyzer/wireshark: IUSE=nghttp2 => IUSE=http2 (diff)
downloadgentoo-5a257242158d5067022f92c7e4b5d22a511b3552.tar.gz
gentoo-5a257242158d5067022f92c7e4b5d22a511b3552.tar.bz2
gentoo-5a257242158d5067022f92c7e4b5d22a511b3552.zip
x11-misc/cbatticon: Version 1.6.10
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/cbatticon/cbatticon-1.6.10.ebuild')
-rw-r--r--x11-misc/cbatticon/cbatticon-1.6.10.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/cbatticon/cbatticon-1.6.10.ebuild b/x11-misc/cbatticon/cbatticon-1.6.10.ebuild
new file mode 100644
index 000000000000..c50d042f8226
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.6.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ strip-linguas -i .
+}
+
+src_compile() {
+ tc-export CC
+ emake \
+ $(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
+ V=1 \
+ VERSION="${PF}" \
+ WITH_GTK3=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}" \
+ LANGUAGES="${LINGUAS}" \
+ V=1 VERSION="${PF}" \
+ install
+
+ dodoc Changelog
+}