summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-28 14:14:04 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-28 14:14:36 +0200
commit4012abe8b06da80e146bacd1ccbfec0af1a255cb (patch)
treecca43b501799235f27599be0a063e39b570749ef /x11-misc/dmenu/dmenu-9999.ebuild
parentAdd ~arm keyword (bug #646506) (diff)
downloadgentoo-4012abe8b06da80e146bacd1ccbfec0af1a255cb.tar.gz
gentoo-4012abe8b06da80e146bacd1ccbfec0af1a255cb.tar.bz2
gentoo-4012abe8b06da80e146bacd1ccbfec0af1a255cb.zip
x11-misc/dmenu: Fix patch, rework src_compile().
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'x11-misc/dmenu/dmenu-9999.ebuild')
-rw-r--r--x11-misc/dmenu/dmenu-9999.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/x11-misc/dmenu/dmenu-9999.ebuild b/x11-misc/dmenu/dmenu-9999.ebuild
index e55ea2292231..5cb15906696b 100644
--- a/x11-misc/dmenu/dmenu-9999.ebuild
+++ b/x11-misc/dmenu/dmenu-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -42,16 +42,15 @@ src_prepare() {
src_compile() {
emake CC=$(tc-getCC) \
- "FREETYPEINC=$( $(tc-getPKG_CONFIG) --cflags x11 fontconfig xft 2>/dev/null )" \
- "FREETYPELIBS=$( $(tc-getPKG_CONFIG) --libs x11 fontconfig xft 2>/dev/null )" \
- "XINERAMAFLAGS=$(
- usex xinerama "-DXINERAMA $(
- $(tc-getPKG_CONFIG) --cflags xinerama 2>/dev/null
- )" ''
- )" \
- "XINERAMALIBS=$(
- usex xinerama "$( $(tc-getPKG_CONFIG) --libs xinerama 2>/dev/null)" ''
- )"
+ INCS=" \
+ $(usex xinerama "-DXINERAMA" '') \
+ $(
+ $(tc-getPKG_CONFIG) --cflags fontconfig freetype2 x11 xft $(usex xinerama xinerama '')
+ )" \
+ LIBS=" \
+ $(
+ $(tc-getPKG_CONFIG) --libs fontconfig x11 xft $(usex xinerama xinerama '')
+ )"
}
src_install() {