summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-03-01 07:37:37 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-04 14:59:11 +0200
commit98c8397688f16da06947dd96c33cb5e97addac50 (patch)
tree4c0194d6cf6cac153ca1822939c3e636d43be052 /x11-misc/dunst/dunst-1.6.1.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.259,4.9.259,4.14.2... (diff)
downloadgentoo-98c8397688f16da06947dd96c33cb5e97addac50.tar.gz
gentoo-98c8397688f16da06947dd96c33cb5e97addac50.tar.bz2
gentoo-98c8397688f16da06947dd96c33cb5e97addac50.zip
x11-misc/dunst: version bump to 1.6.1
new maintainer Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/19719 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/dunst/dunst-1.6.1.ebuild')
-rw-r--r--x11-misc/dunst/dunst-1.6.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/dunst/dunst-1.6.1.ebuild b/x11-misc/dunst/dunst-1.6.1.ebuild
new file mode 100644
index 000000000000..b4ea0aaabb02
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Customizable and lightweight notification-daemon"
+HOMEPAGE="https://dunst-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dunst-project/dunst"
+else
+ SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test wayland"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libnotify
+ x11-libs/pango[X]
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-no-Os.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+ default
+}
+
+src_compile() {
+ emake WAYLAND=$(usex wayland 1 0) SYSTEMD=0
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" \
+ -i dunst.systemd.service.in > dunst.service
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ systemd_dounit dunst.service
+}