summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 23:21:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 23:22:28 +0200
commitd4cd7d9dc3e0951944f93f5ae32348bebfac7718 (patch)
treebb97bfa7bf02a2e9c905281902a12552787f7901 /x11-misc/flow-pomodoro
parentapp-emacs/prom-wl: Remove last-rited pkg (diff)
downloadgentoo-d4cd7d9dc3e0951944f93f5ae32348bebfac7718.tar.gz
gentoo-d4cd7d9dc3e0951944f93f5ae32348bebfac7718.tar.bz2
gentoo-d4cd7d9dc3e0951944f93f5ae32348bebfac7718.zip
x11-misc/flow-pomodoro: Fix popups with Qt 5.12, EAPI-7 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/flow-pomodoro')
-rw-r--r--x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-qt-5.12.patch33
-rw-r--r--x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild28
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-qt-5.12.patch b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-qt-5.12.patch
new file mode 100644
index 000000000000..05ff231d9ea7
--- /dev/null
+++ b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-qt-5.12.patch
@@ -0,0 +1,33 @@
+From 53dfa7dd18290225a62b1cfd10b5566ab90a3fe8 Mon Sep 17 00:00:00 2001
+From: Sergio Martins <iamsergio@gmail.com>
+Date: Fri, 17 Aug 2018 16:22:04 +0100
+Subject: [PATCH] Fix popups with Qt 5.12 (QTBUG-70031)
+
+---
+ src/qml/ChoicePopup.qml | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/qml/ChoicePopup.qml b/src/qml/ChoicePopup.qml
+index b66359d..6418b54 100644
+--- a/src/qml/ChoicePopup.qml
++++ b/src/qml/ChoicePopup.qml
+@@ -92,7 +92,7 @@ Item {
+ radius: 2 * _controller.dpiFactor
+
+ Column {
+- id: column
++ id: column1
+ anchors.fill: parent
+
+ Rectangle {
+@@ -136,8 +136,8 @@ Item {
+ model: root.model
+ Choice {
+ objectName: "taskMenuChoice"
+- anchors.left: column.left
+- anchors.right: column.right
++ anchors.left: column1.left
++ anchors.right: column1.right
+ topLineVisible: index > 0
+ height: root.delegateHeight
+ fontAwesomeIconCode: iconRole
diff --git a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..4285248dec78
--- /dev/null
+++ b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A pomodoro app that blocks distractions while you work"
+HOMEPAGE="https://github.com/iamsergio/flow-pomodoro"
+SRC_URI="https://github.com/iamsergio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.12.patch" )