summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-24 16:12:59 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-24 16:13:15 +1000
commitdc1a1d3f206ac6ce9c54acd7648f1c0311d4f110 (patch)
tree88190eaa1f6022a2e9ac601f92cf163d0b7347c2 /x11-misc/fraqtive
parentnet-dialup/cutecom: remove 0.22.0-r1 (diff)
downloadgentoo-dc1a1d3f206ac6ce9c54acd7648f1c0311d4f110.tar.gz
gentoo-dc1a1d3f206ac6ce9c54acd7648f1c0311d4f110.tar.bz2
gentoo-dc1a1d3f206ac6ce9c54acd7648f1c0311d4f110.zip
x11-misc/fraqtive: fix build failure by adding patch with missing Qt includes
Closes: https://bugs.gentoo.org/563574 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'x11-misc/fraqtive')
-rw-r--r--x11-misc/fraqtive/files/fraqtive-0.4.8-qt-includes.patch24
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.8.ebuild4
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-misc/fraqtive/files/fraqtive-0.4.8-qt-includes.patch b/x11-misc/fraqtive/files/fraqtive-0.4.8-qt-includes.patch
new file mode 100644
index 000000000000..de31d9c37ec2
--- /dev/null
+++ b/x11-misc/fraqtive/files/fraqtive-0.4.8-qt-includes.patch
@@ -0,0 +1,24 @@
+Add missing Qt includes.
+
+Bug: https://bugs.gentoo.org/563574
+
+--- a/src/configurationdata.cpp
++++ b/src/configurationdata.cpp
+@@ -25,6 +25,7 @@
+ #include <shlobj.h>
+ #endif
+
++#include <QDataStream>
+ #include <QDir>
+ #include <cstdlib>
+
+--- a/src/fractalgenerator.h
++++ b/src/fractalgenerator.h
+@@ -21,6 +21,7 @@
+
+ #include <QEvent>
+ #include <QMutex>
++#include <QObject>
+ #include <QWaitCondition>
+
+ #include "abstractjobprovider.h"
diff --git a/x11-misc/fraqtive/fraqtive-0.4.8.ebuild b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
index 8d3effac98fe..5c0a787ab56a 100644
--- a/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
+++ b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -32,6 +32,8 @@ DEPEND="
"
src_configure() {
+ epatch "${FILESDIR}/${P}-qt-includes.patch"
+
tc-export PKG_CONFIG
sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
local conf="release"