summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-11-29 19:37:15 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-11-29 19:37:44 +0000
commit365a9bf1faf2dc583d7b72bd1b28bc6087559c7a (patch)
tree819e53ddd8b77e3bc0e714f09c2f819d170aa2d2 /x11-misc/gigolo/gigolo-0.4.2-r1.ebuild
parentx11-wm/i3: Add missing dependency xkeyboard-config (diff)
downloadgentoo-365a9bf1faf2dc583d7b72bd1b28bc6087559c7a.tar.gz
gentoo-365a9bf1faf2dc583d7b72bd1b28bc6087559c7a.tar.bz2
gentoo-365a9bf1faf2dc583d7b72bd1b28bc6087559c7a.zip
x11-misc/gigolo: remove obsolete xfconf.eclass, migrate to EAPI6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'x11-misc/gigolo/gigolo-0.4.2-r1.ebuild')
-rw-r--r--x11-misc/gigolo/gigolo-0.4.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/gigolo/gigolo-0.4.2-r1.ebuild b/x11-misc/gigolo/gigolo-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..2530f306a062
--- /dev/null
+++ b/x11-misc/gigolo/gigolo-0.4.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils
+
+DESCRIPTION="a frontend to easily manage connections to remote filesystems using GIO/GVfs"
+HOMEPAGE="http://www.uvena.de/gigolo/ https://goodies.xfce.org/projects/applications/gigolo"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.12:2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -f COPYING || die
+ default
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}