summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucian.poston@gmail.com>2018-01-18 15:17:33 -0800
committerAaron Bauman <bman@gentoo.org>2018-05-24 16:56:30 -0400
commite94cedb60f09c43a0cffd293282d8d4d7cfed895 (patch)
tree75a16fc0dbf821cae0f02e696f81ce9955185d8a /x11-misc/gmrun/gmrun-0.9.2-r2.ebuild
parentapp-shells/thefuck: drop old versions. (diff)
downloadgentoo-e94cedb60f09c43a0cffd293282d8d4d7cfed895.tar.gz
gentoo-e94cedb60f09c43a0cffd293282d8d4d7cfed895.tar.bz2
gentoo-e94cedb60f09c43a0cffd293282d8d4d7cfed895.zip
x11-misc/gmrun: Add 0.9.2-r2 w/ gcc-6 pie patch
Closes: https://bugs.gentoo.org/640018 Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6903
Diffstat (limited to 'x11-misc/gmrun/gmrun-0.9.2-r2.ebuild')
-rw-r--r--x11-misc/gmrun/gmrun-0.9.2-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/gmrun/gmrun-0.9.2-r2.ebuild b/x11-misc/gmrun/gmrun-0.9.2-r2.ebuild
new file mode 100644
index 000000000000..b2ce6fb13cbd
--- /dev/null
+++ b/x11-misc/gmrun/gmrun-0.9.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
+HOMEPAGE="https://sourceforge.net/projects/gmrun/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/popt
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.10 )
+ sys-apps/sed
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc6-pie.patch \
+ "${FILESDIR}"/${P}-sysconfdir.patch \
+ "${FILESDIR}"/${P}-glibc210.patch \
+ "${FILESDIR}"/${P}-stlport.patch
+
+ eapply_user
+ eautoreconf
+}