summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-02-20 19:26:17 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-02-20 20:24:56 +0100
commit02653bc04ab68205e229fb04e96db27613e223ca (patch)
tree5378f16670f9c8f14a62f17ae40faa39a80fe9ae /x11-misc/i3blocks/i3blocks-1.4-r1.ebuild
parentsci-biology/meme: Remove use of 'diropts' (diff)
downloadgentoo-02653bc04ab68205e229fb04e96db27613e223ca.tar.gz
gentoo-02653bc04ab68205e229fb04e96db27613e223ca.tar.bz2
gentoo-02653bc04ab68205e229fb04e96db27613e223ca.zip
x11-misc/i3blocks: revbump, fixes bug #610090
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-misc/i3blocks/i3blocks-1.4-r1.ebuild')
-rw-r--r--x11-misc/i3blocks/i3blocks-1.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/i3blocks/i3blocks-1.4-r1.ebuild b/x11-misc/i3blocks/i3blocks-1.4-r1.ebuild
new file mode 100644
index 000000000000..f932aa4e535e
--- /dev/null
+++ b/x11-misc/i3blocks/i3blocks-1.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="highly flexible status line for the i3 window manager"
+HOMEPAGE="https://github.com/vivien/i3blocks"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vivien/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/vivien/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="0"
+LICENSE="GPL-3"
+
+RDEPEND="app-admin/sysstat
+ media-sound/playerctl
+ sys-apps/lm_sensors
+ sys-power/acpi
+ x11-wm/i3"
+
+DEPEND="app-text/ronn"
+
+PATCHES=( "${FILESDIR}/${PN}-default-sysconfdir.patch" ) #610090
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}