summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-01-06 08:41:51 -0600
committerKacper Kowalik <xarthisius@gentoo.org>2016-01-06 08:41:51 -0600
commitb3d5558c2778adf5f80e1444ba62d7af2b80d5db (patch)
tree92ccb4fee93876e37533052eb15607ffaa9b1002 /x11-misc/i3status/files
parentprofiles/package.mask: Clean cruft (diff)
downloadgentoo-b3d5558c2778adf5f80e1444ba62d7af2b80d5db.tar.gz
gentoo-b3d5558c2778adf5f80e1444ba62d7af2b80d5db.tar.bz2
gentoo-b3d5558c2778adf5f80e1444ba62d7af2b80d5db.zip
x11-misc/i3status: make dependency on pulseaudio optional
Fixes bug #570786 and introduces the new USE flag 'pulseaudio'. Reported-by: Michele Alzetta <michele@alzetta.org>
Diffstat (limited to 'x11-misc/i3status/files')
-rw-r--r--x11-misc/i3status/files/i3status-2.10-pulseaudio.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/i3status/files/i3status-2.10-pulseaudio.patch b/x11-misc/i3status/files/i3status-2.10-pulseaudio.patch
new file mode 100644
index 000000000000..991ce036cd4f
--- /dev/null
+++ b/x11-misc/i3status/files/i3status-2.10-pulseaudio.patch
@@ -0,0 +1,46 @@
+Make dependency on pulseaudio optional.
+
+It's unfortunately not upstreamable. See:
+
+https://github.com/i3/i3status/pull/43
+https://bugs.gentoo.org/show_bug.cgi?id=570786
+
+--- a/Makefile
++++ b/Makefile
+@@ -49,6 +49,10 @@ ifeq ($(OS),NetBSD)
+ LIBS+=-lprop
+ endif
+
++ifeq ($(OS),OpenBSD)
++LIBS+=-lpthread
++endif
++
+ # This probably applies for any pkgsrc based system
+ ifneq (, $(filter $(OS), NetBSD DragonFly))
+ CFLAGS+=-I/usr/pkg/include/
+@@ -70,9 +74,12 @@ CFLAGS += -idirafter yajl-fallback
+ OBJS:=$(wildcard src/*.c *.c)
+ OBJS:=$(OBJS:.c=.o)
+
+-ifeq ($(OS),OpenBSD)
++PULSE ?= 1
++ifeq ($(PULSE),0)
+ OBJS:=$(filter-out src/pulse.o, $(OBJS))
+-LIBS:=$(filter-out -lpulse, $(LIBS)) -lpthread
++LIBS:=$(filter-out -lpulse, $(LIBS))
++else
++CPPFLAGS+=-DPULSE
+ endif
+
+ src/%.o: src/%.c include/i3status.h
+--- a/src/print_volume.c
++++ b/src/print_volume.c
+@@ -60,7 +60,7 @@ void print_volume(yajl_gen json_gen, char *buffer, const char *fmt, const char *
+ free(instance);
+ }
+
+-#ifndef __OpenBSD__
++#if !defined(__OpenBSD__) && defined(PULSE)
+ /* Try PulseAudio first */
+
+ /* If the device name has the format "pulse[:N]" where N is the