summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-17 17:00:32 +0000
committerSam James <sam@gentoo.org>2022-07-17 17:02:32 +0000
commit20f9b659b43f3536e9337878e448e1ad96a67ab0 (patch)
tree6cbc7f652d58bec3f9aaa1fd10d7b733d6e6e5e5 /x11-misc/idesk
parentx11-misc/idesk: update upstream PR link (diff)
downloadgentoo-20f9b659b43f3536e9337878e448e1ad96a67ab0.tar.gz
gentoo-20f9b659b43f3536e9337878e448e1ad96a67ab0.tar.bz2
gentoo-20f9b659b43f3536e9337878e448e1ad96a67ab0.zip
x11-misc/idesk: add 0.7.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/idesk')
-rw-r--r--x11-misc/idesk/Manifest1
-rw-r--r--x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch1
-rw-r--r--x11-misc/idesk/idesk-0.7.8.ebuild51
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/idesk/Manifest b/x11-misc/idesk/Manifest
index 4a677bc53c3c..eaea35d0026c 100644
--- a/x11-misc/idesk/Manifest
+++ b/x11-misc/idesk/Manifest
@@ -1 +1,2 @@
+DIST idesk-0.7.8.tar.gz 202949 BLAKE2B 93f902ab8b073d5b8e4a03d65ce99379e4adcf7ae6220be858ef7f1ce1f326cbbcc50c6d99424d8153ad498c9498939f39c51de1aa231c392a18636ee53788ee SHA512 0456646788ab70d1fc05ee0fc5f9d811f9f67c2420039ec525f42b6634ec92c1e3f8f061af5c407a22ab81db873efde216ad5c4fccba6fb27f1777d2e66a5535
DIST idesk-v1.tar.gz 195147 BLAKE2B 2b2b0dacbfb1d8fb950c88d990e3674bf8b4cf82d9022ed2f7be1f32082c46ae32d8200957e2e19d0d21ea1e4d59ec092f4cba90e712f79700a04f05c3a3aa14 SHA512 3190fca7a5c9fb36b66159107d22b5f6e50b4573afa21a3a4d8b8e3e5953dabda077c924e45d2607b849ee5fea141eb80f5b89ce5288ebc2490679f319edf768
diff --git a/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch b/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
index 4e9849dabb00..7f062c94280f 100644
--- a/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
+++ b/x11-misc/idesk/files/idesk-1-use-pkg-config-imlib2.patch
@@ -1,5 +1,6 @@
https://github.com/antonialoytorrens/idesk/pull/1
https://github.com/neagix/idesk/pull/9
+https://github.com/neagix/idesk/issues/7
From b13626bbe2669b8a267ad53df93f1060379a462e Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
diff --git a/x11-misc/idesk/idesk-0.7.8.ebuild b/x11-misc/idesk/idesk-0.7.8.ebuild
new file mode 100644
index 000000000000..16d07105e02b
--- /dev/null
+++ b/x11-misc/idesk/idesk-0.7.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Utility to place icons on the root window"
+HOMEPAGE="https://github.com/neagix/idesk"
+SRC_URI="https://github.com/neagix/idesk/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="svg"
+
+RDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2
+ media-libs/freetype
+ media-libs/imlib2[X]
+ media-libs/libart_lgpl
+ x11-libs/libXft
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-libs/startup-notification
+ svg? (
+ gnome-base/librsvg
+ x11-libs/gdk-pixbuf
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1-use-pkg-config-imlib2.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's,/usr/local/,/usr/,' examples/default.lnk || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-libsn \
+ $(use_enable svg)
+}