summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2016-11-24 12:26:10 +0300
committerAlexander Vershilov <qnikst@gentoo.org>2016-11-24 12:26:10 +0300
commit756c5c5d4a839d6ba42fe5d175543b5410014be4 (patch)
tree90ae1e684f176dd732559572c3c59bd9af2650ff /x11-misc/kbdd/kbdd-0.7.1.ebuild
parentsys-fs/rarfs: revision bump (diff)
downloadgentoo-756c5c5d4a839d6ba42fe5d175543b5410014be4.tar.gz
gentoo-756c5c5d4a839d6ba42fe5d175543b5410014be4.tar.bz2
gentoo-756c5c5d4a839d6ba42fe5d175543b5410014be4.zip
x11-misc/kbdd: bump up to 0.7.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-misc/kbdd/kbdd-0.7.1.ebuild')
-rw-r--r--x11-misc/kbdd/kbdd-0.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/kbdd/kbdd-0.7.1.ebuild b/x11-misc/kbdd/kbdd-0.7.1.ebuild
new file mode 100644
index 000000000000..fbf1249cc4c9
--- /dev/null
+++ b/x11-misc/kbdd/kbdd-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Very simple layout switcher"
+HOMEPAGE="https://github.com/qnikst/kbdd"
+SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="dev-libs/glib:2=
+ x11-libs/libX11:0=
+ dbus? (
+ sys-apps/dbus:0=
+ >=dev-libs/dbus-glib-0.86:0=
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable dbus)
+}