summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-30 09:59:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-30 09:59:52 +0200
commit471fa32b97d78be42a08afb523ca578053989db8 (patch)
treee9f2dd1bd4721b8633e489ce5e5b32d53a524ed7 /x11-misc/lightdm
parentx11-misc/lightdm: Fixed lightdm Xsession wrapper to report only really source... (diff)
downloadgentoo-471fa32b97d78be42a08afb523ca578053989db8.tar.gz
gentoo-471fa32b97d78be42a08afb523ca578053989db8.tar.bz2
gentoo-471fa32b97d78be42a08afb523ca578053989db8.zip
x11-misc/lightdm: Revbump for changed Xsession file.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-misc/lightdm')
-rw-r--r--x11-misc/lightdm/files/Xsession60
-rw-r--r--x11-misc/lightdm/lightdm-1.30.0-r1.ebuild (renamed from x11-misc/lightdm/lightdm-1.30.0.ebuild)0
2 files changed, 30 insertions, 30 deletions
diff --git a/x11-misc/lightdm/files/Xsession b/x11-misc/lightdm/files/Xsession
index d982a0ac89e9..1fe0110c9d9b 100644
--- a/x11-misc/lightdm/files/Xsession
+++ b/x11-misc/lightdm/files/Xsession
@@ -5,36 +5,36 @@
echo "Running X session wrapper"
# Load profile
-for file in "/etc/profile" "$HOME/.profile" "/etc/xprofile" "$HOME/.xprofile"; do
- if [ -f "$file" ]; then
- echo "Loading profile from $file";
- . "$file"
+for file in "/etc/profile" "${HOME}/.profile" "/etc/xprofile" "${HOME}/.xprofile" ; do
+ if [ -f "${file}" ] ; then
+ echo "Loading profile from ${file}";
+ . "${file}"
fi
done
# Load resources
-for file in "/etc/X11/Xresources" "$HOME/.Xresources"; do
- if [ -f "$file" ]; then
- echo "Loading resource: $file"
- xrdb -nocpp -merge "$file"
+for file in "/etc/X11/Xresources" "${HOME}/.Xresources" ; do
+ if [ -f "${file}" ] ; then
+ echo "Loading resource: ${file}"
+ xrdb -nocpp -merge "${file}"
fi
done
# Load keymaps
-for file in "/etc/X11/Xkbmap" "$HOME/.Xkbmap"; do
- if [ -f "$file" ]; then
- echo "Loading keymap: $file"
- setxkbmap `cat "$file"`
+for file in "/etc/X11/Xkbmap" "${HOME}/.Xkbmap" ; do
+ if [ -f "${file}" ] ; then
+ echo "Loading keymap: ${file}"
+ setxkbmap $(cat "${file}")
XKB_IN_USE=yes
fi
done
# Load xmodmap if not using XKB
-if [ -z "$XKB_IN_USE" ]; then
- for file in "/etc/X11/Xmodmap" "$HOME/.Xmodmap"; do
- if [ -f "$file" ]; then
- echo "Loading modmap: $file"
- xmodmap "$file"
+if [ -z "${XKB_IN_USE}" ] ; then
+ for file in "/etc/X11/Xmodmap" "${HOME}/.Xmodmap" ; do
+ if [ -f "${file}" ] ; then
+ echo "Loading modmap: ${file}"
+ xmodmap "${file}"
fi
done
fi
@@ -48,27 +48,27 @@ command="$@"
# Run all system xinitrc shell scripts.
xinitdir="/etc/X11/xinit/xinitrc.d"
-if [ -d "$xinitdir" ]; then
- for script in $xinitdir/*; do
- if [ -x "$script" -a ! -d "$script" ]; then
- echo "Loading xinit script $script"
- . "$script"
+if [ -d "${xinitdir}" ] ; then
+ for script in ${xinitdir}/* ; do
+ if [ -x "${script}" ] && [ ! -d "${script}" ] ; then
+ echo "Loading xinit script ${script}"
+ . "${script}"
fi
done
fi
# Load Xsession scripts
xsessionddir="/etc/X11/Xsession.d"
-if [ -d "$xsessionddir" ]; then
- for i in `ls $xsessionddir`; do
- script="$xsessionddir/$i"
- if [ -r "$script" -a -f "$script" ] && expr "$i" : '^[[:alnum:]_-]\+$' > /dev/null; then
- echo "Loading X session script $script"
- . "$script"
+if [ -d "${xsessionddir}" ] ; then
+ for i in $(ls ${xsessionddir}) ; do
+ script="${xsessionddir}/${i}"
+ if [ -r "${script}" ] && [ -f "${script}" ] && expr "${i}" : '^[[:alnum:]_-]\+$' > /dev/null ; then
+ echo "Loading X session script ${script}"
+ . "${script}"
fi
done
fi
-echo "X session wrapper complete, running session $@"
+echo "X session wrapper complete, running session ${@}"
-exec $command
+exec ${command}
diff --git a/x11-misc/lightdm/lightdm-1.30.0.ebuild b/x11-misc/lightdm/lightdm-1.30.0-r1.ebuild
index ea3868227341..ea3868227341 100644
--- a/x11-misc/lightdm/lightdm-1.30.0.ebuild
+++ b/x11-misc/lightdm/lightdm-1.30.0-r1.ebuild