summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/macopix/macopix-1.7.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/macopix/macopix-1.7.4.ebuild')
-rw-r--r--x11-misc/macopix/macopix-1.7.4.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/macopix/macopix-1.7.4.ebuild b/x11-misc/macopix/macopix-1.7.4.ebuild
new file mode 100644
index 000000000000..d3041a97f936
--- /dev/null
+++ b/x11-misc/macopix/macopix-1.7.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+DESCRIPTION="MaCoPiX (Mascot Constructive Pilot for X) is a desktop mascot application on UNIX / X Window system"
+HOMEPAGE="http://rosegray.sakura.ne.jp/macopix/index-e.html"
+
+BASE_URI="http://rosegray.sakura.ne.jp/macopix"
+SRC_URI="${BASE_URI}/${P}.tar.bz2"
+
+# NOTE: These mascots are not redistributable on commercial CD-ROM.
+# The author granted to use them under Gentoo Linux.
+MY_MASCOTS="macopix-mascot-HxB-euc-ja-0.30
+ macopix-mascot-marimite-euc-ja-2.20
+ macopix-mascot-cosmos-euc-ja-1.02
+ macopix-mascot-mizuiro-euc-ja-1.02
+ macopix-mascot-pia2-euc-ja-1.02
+ macopix-mascot-tsukihime-euc-ja-1.02
+ macopix-mascot-triangle_heart-euc-ja-1.02
+ macopix-mascot-comic_party-euc-ja-1.02
+ macopix-mascot-kanon-euc-ja-1.02
+ macopix-mascot-one-euc-ja-1.02"
+
+for i in ${MY_MASCOTS} ; do
+ SRC_URI="${SRC_URI} ${BASE_URI}/${i}.tar.gz"
+done
+
+# programme itself is GPL-2, and mascots are free-noncomm
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="gnutls nls"
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ nls? ( >=sys-devel/gettext-0.10 )
+ media-libs/libpng
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ export LIBS="-lX11"
+ econf \
+ --with-gtk2 \
+ $(use_enable nls) \
+ $(use_with gnutls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS *README* || die
+
+ # install mascots
+ for d in ${MY_MASCOTS} ; do
+ einfo "Installing ${d}..."
+ cd "${WORKDIR}/${d}" || die
+ insinto /usr/share/"${PN}"
+ for i in *.mcpx *.menu ; do
+ doins "$i" || die
+ done
+ insinto /usr/share/"${PN}"/pixmap
+ for i in *.png ; do
+ doins "$i" || die
+ done
+ docinto "${d}"
+ dodoc README.jp || die
+ done
+}