summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 14:47:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 19:05:34 +0200
commit566168baf8031c699aea3b7868ab77a5cdf73218 (patch)
treeaa42df6ed1508a19866d7bd9d97becf0daf183ec /x11-misc/macopix
parentprofiles: Mask app-editors/amyedit for removal (diff)
downloadgentoo-566168baf8031c699aea3b7868ab77a5cdf73218.tar.gz
gentoo-566168baf8031c699aea3b7868ab77a5cdf73218.tar.bz2
gentoo-566168baf8031c699aea3b7868ab77a5cdf73218.zip
x11-misc/macopix: Fix build with >=dev-libs/openssl-1.1.0
See also: https://www.openssl.org/docs/man1.1.0/man3/ERR_free_strings.html Closes: https://bugs.gentoo.org/756322 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/macopix')
-rw-r--r--x11-misc/macopix/files/macopix-3.4.0-openssl-1.1.0.patch10
-rw-r--r--x11-misc/macopix/macopix-3.4.0.ebuild7
2 files changed, 15 insertions, 2 deletions
diff --git a/x11-misc/macopix/files/macopix-3.4.0-openssl-1.1.0.patch b/x11-misc/macopix/files/macopix-3.4.0-openssl-1.1.0.patch
new file mode 100644
index 000000000000..7d816e7d5e50
--- /dev/null
+++ b/x11-misc/macopix/files/macopix-3.4.0-openssl-1.1.0.patch
@@ -0,0 +1,10 @@
+--- a/src/http-client.c
++++ b/src/http-client.c
+@@ -516,7 +516,6 @@
+ SSL_shutdown(ssl);
+ SSL_free(ssl);
+ SSL_CTX_free(ctx);
+- ERR_free_strings();
+
+ close(command_socket);
+
diff --git a/x11-misc/macopix/macopix-3.4.0.ebuild b/x11-misc/macopix/macopix-3.4.0.ebuild
index b7351081a80f..27f14273a81f 100644
--- a/x11-misc/macopix/macopix-3.4.0.ebuild
+++ b/x11-misc/macopix/macopix-3.4.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="MaCoPiX (Mascot Constructive Pilot for X) is a desktop mascot application"
@@ -43,15 +44,17 @@ RDEPEND="
!gnutls? ( dev-libs/openssl:0= )
x11-libs/gtk+:3
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
"
+
PATCHES=(
"${FILESDIR}"/${PN}-3.4.0-CVE-2015-8614.patch
"${FILESDIR}"/${PN}-3.4.0-Werror.patch
"${FILESDIR}"/${PN}-3.4.0-fno-common.patch
"${FILESDIR}"/${PN}-3.4.0-windres.patch
+ "${FILESDIR}"/${PN}-3.4.0-openssl-1.1.0.patch
)
src_prepare() {