summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-29 02:37:29 +0100
committerSam James <sam@gentoo.org>2021-04-29 02:51:49 +0100
commit2c638ff15b6240a05d7382709f125d9561eda5eb (patch)
tree360a253ab8872bb9fd5019019cfeb0e24b2155d5 /x11-misc/matchbox-keyboard
parentx11-misc/matchbox-keyboard: fix variable reference style (diff)
downloadgentoo-2c638ff15b6240a05d7382709f125d9561eda5eb.tar.gz
gentoo-2c638ff15b6240a05d7382709f125d9561eda5eb.tar.bz2
gentoo-2c638ff15b6240a05d7382709f125d9561eda5eb.zip
x11-misc/matchbox-keyboard: drop unused eutils inherit
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/matchbox-keyboard')
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
index 98f5cedb69c5..4ceed10c88e9 100644
--- a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
@@ -3,25 +3,26 @@
EAPI="6"
-inherit versionator eutils
+inherit versionator
DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard"
HOMEPAGE="http://matchbox-project.org/"
SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ~arm ~hppa ppc x86"
IUSE="debug cairo"
-DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
-PATCHES=( "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch )
-
DEPEND="x11-libs/libfakekey
cairo? ( x11-libs/cairo[X] )
!cairo? ( x11-libs/libXft )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch
+)
+
src_configure() {
econf $(use_enable debug) $(use_enable cairo)
}