summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2016-12-05 16:07:56 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2016-12-05 16:14:24 -0500
commitdd3ffccf496c1f6de8457cf710de037e87b3603b (patch)
tree1b440e5cdbc8b31a41d6630c16be40d29bc579ec /x11-misc/menumaker/menumaker-0.99.9.ebuild
parentdev-libs/boost-mpl-cartesian_product: initial commit (diff)
downloadgentoo-dd3ffccf496c1f6de8457cf710de037e87b3603b.tar.gz
gentoo-dd3ffccf496c1f6de8457cf710de037e87b3603b.tar.bz2
gentoo-dd3ffccf496c1f6de8457cf710de037e87b3603b.zip
x11-misc/menumaker: bump to 0.99.9
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/menumaker/menumaker-0.99.9.ebuild')
-rw-r--r--x11-misc/menumaker/menumaker-0.99.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/menumaker/menumaker-0.99.9.ebuild b/x11-misc/menumaker/menumaker-0.99.9.ebuild
new file mode 100644
index 000000000000..20171d7b0984
--- /dev/null
+++ b/x11-misc/menumaker/menumaker-0.99.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
+HOMEPAGE="http://menumaker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE="doc"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( sys-apps/texinfo )"
+
+src_configure() {
+ PYTHON_BIN="${PYTHON}" econf
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd doc || die
+ emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ python_optimize "${D}"/usr/share/menumaker
+
+ if use doc; then
+ docinto html
+ dodoc doc/mmaker.html/*
+ fi
+}