summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-25 16:26:19 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:48:54 -0400
commit2e0a7c1bb930377eb5a2edb491d40f26ed547bca (patch)
treed91569eb9632c0fd617d09825f6575a492eee080 /x11-misc/mozo/mozo-1.24.0.ebuild
parentmate-extra/mate-utils: Fix LICENSE (diff)
downloadgentoo-2e0a7c1bb930377eb5a2edb491d40f26ed547bca.tar.gz
gentoo-2e0a7c1bb930377eb5a2edb491d40f26ed547bca.tar.bz2
gentoo-2e0a7c1bb930377eb5a2edb491d40f26ed547bca.zip
x11-misc/mozo: Bump to 1.24.0
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-misc/mozo/mozo-1.24.0.ebuild')
-rw-r--r--x11-misc/mozo/mozo-1.24.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/mozo/mozo-1.24.0.ebuild b/x11-misc/mozo/mozo-1.24.0.ebuild
new file mode 100644
index 000000000000..22077e71c14f
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.24.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ !!x11-misc/mate-menu-editor
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ virtual/pkgconfig:*
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}