summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 11:19:47 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-30 18:41:50 -0400
commit289a0c457ab94542158a6ba8d4e851d452382bc7 (patch)
treec94b079839e54448a9145d1d51808daae84b1e67 /x11-misc/mozo/mozo-1.24.1.ebuild
parentmedia-gfx/eom: Bump to 1.24.2 (diff)
downloadgentoo-289a0c457ab94542158a6ba8d4e851d452382bc7.tar.gz
gentoo-289a0c457ab94542158a6ba8d4e851d452382bc7.tar.bz2
gentoo-289a0c457ab94542158a6ba8d4e851d452382bc7.zip
x11-misc/mozo: Bump to 1.24.1
Bug: https://bugs.gentoo.org/778857 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'x11-misc/mozo/mozo-1.24.1.ebuild')
-rw-r--r--x11-misc/mozo/mozo-1.24.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/mozo/mozo-1.24.1.ebuild b/x11-misc/mozo/mozo-1.24.1.ebuild
new file mode 100644
index 000000000000..2b73ccc26492
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.24.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_REQ_USE="xml"
+
+inherit mate python-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ !!x11-misc/mate-menu-editor
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}