summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-08 00:18:11 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-08 00:31:59 +0200
commit4469e971664da6f89be3c46dedccb2334030df3e (patch)
tree58902eb2174ff4f750d94ceefabdfe42d2873c73 /x11-misc/notification-daemon/notification-daemon-3.20.0.ebuild
parentdev-util/gtk-doc-am: version bump to 1.25-r1 (diff)
downloadgentoo-4469e971664da6f89be3c46dedccb2334030df3e.tar.gz
gentoo-4469e971664da6f89be3c46dedccb2334030df3e.tar.bz2
gentoo-4469e971664da6f89be3c46dedccb2334030df3e.zip
x11-misc/notification-daemon: version bump from 3.18.2 to 3.20.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/notification-daemon/notification-daemon-3.20.0.ebuild')
-rw-r--r--x11-misc/notification-daemon/notification-daemon-3.20.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon/notification-daemon-3.20.0.ebuild b/x11-misc/notification-daemon/notification-daemon-3.20.0.ebuild
new file mode 100644
index 000000000000..92f703b5ecef
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-3.20.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome.org
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="https://git.gnome.org/browse/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.19.5:3
+ sys-apps/dbus
+ x11-libs/libX11
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ cat <<-EOF > "${T}"/org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+
+ insinto /usr/share/dbus-1/services
+ doins "${T}"/org.freedesktop.Notifications.service
+}