summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 23:20:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:38 +0100
commitca1ab8a65895a6e3074a8537c7a372c51d28b047 (patch)
tree759624750b7ca88de31015eeb4c95e0c4641a767 /x11-misc/obconf-qt/obconf-qt-0.16.0.ebuild
parentx11-misc/qps: add version 2.2.0 (diff)
downloadgentoo-ca1ab8a65895a6e3074a8537c7a372c51d28b047.tar.gz
gentoo-ca1ab8a65895a6e3074a8537c7a372c51d28b047.tar.bz2
gentoo-ca1ab8a65895a6e3074a8537c7a372c51d28b047.zip
x11-misc/obconf-qt: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/obconf-qt/obconf-qt-0.16.0.ebuild')
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.16.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/obconf-qt/obconf-qt-0.16.0.ebuild b/x11-misc/obconf-qt/obconf-qt-0.16.0.ebuild
new file mode 100644
index 000000000000..cec157f207b0
--- /dev/null
+++ b/x11-misc/obconf-qt/obconf-qt-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Openbox Configuration Tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ sys-apps/sed
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-wm/openbox:3
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}