summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/outwiker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/outwiker')
-rw-r--r--x11-misc/outwiker/Manifest2
-rw-r--r--x11-misc/outwiker/metadata.xml11
-rw-r--r--x11-misc/outwiker/outwiker-1.7.0.ebuild37
-rw-r--r--x11-misc/outwiker/outwiker-1.8.0.ebuild35
4 files changed, 85 insertions, 0 deletions
diff --git a/x11-misc/outwiker/Manifest b/x11-misc/outwiker/Manifest
new file mode 100644
index 000000000000..e83be6b86381
--- /dev/null
+++ b/x11-misc/outwiker/Manifest
@@ -0,0 +1,2 @@
+DIST outwiker-1.7.0-src-full.tar.gz 17740708 SHA256 63adca029e5f2384bb2e865bc72b1a89dc78f2495396acb519a4aa663a4dc29c SHA512 9b776010847f91302c4469462124b7c986bb9fe58ff998c5979f00ab1ba03064fb8f89135406ad050346cae5a3403742e173561193f0c7c7676859d80a613d6f WHIRLPOOL 0e95b6548c1185ec06233e612019ea8487aefab6215daf5142455906c7bc0d38e71aa5c4a4c9d166a4f5a219435019de9004a1711033e9057e4602154e4d75b7
+DIST outwiker-1.8.0.tar.gz 27931330 SHA256 b000980b7c744000f1876860c163a27b5c9513ceb04dc77f4fbe974bfdf1a060 SHA512 d4b669383c8c1c95683e8f38617618583076f25db4c3eac778644c9bceeb1e78a7574a1dbea962e2d513e5a0349fced52608a470eb7b6c84dbf83a09c0256df6 WHIRLPOOL 10f0f13188a7da3bf12c15f64b23ba751d74d0fb4757cd3ab4db4d0b64a49177c0cb792f95b6dfc7d716a45b54671ca72c8642d753070e3aa071371a9f5bfea5
diff --git a/x11-misc/outwiker/metadata.xml b/x11-misc/outwiker/metadata.xml
new file mode 100644
index 000000000000..5c22da2a8ddd
--- /dev/null
+++ b/x11-misc/outwiker/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Jenyay/outwiker</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/outwiker/outwiker-1.7.0.ebuild b/x11-misc/outwiker/outwiker-1.7.0.ebuild
new file mode 100644
index 000000000000..8cdf33b5b200
--- /dev/null
+++ b/x11-misc/outwiker/outwiker-1.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_DEPEND="2:2.7"
+inherit python
+
+DESCRIPTION="The tree notes organizer"
+HOMEPAGE="http://jenyay.net/Outwiker/English"
+SRC_URI="http://jenyay.net/uploads/Soft/Outwiker/${P}-src-full.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pywebkitgtk
+ dev-python/wxpython"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ # fix desktop file
+ sed -i -e 's/Application;//' outwiker.desktop || die 'sed on outwiker.desktop failed'
+}
+
+src_compile() { :; }
+
+pkg_postinst() {
+ python_mod_optimize "${ED}/usr/share/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ED}/usr/share/${PN}"
+}
diff --git a/x11-misc/outwiker/outwiker-1.8.0.ebuild b/x11-misc/outwiker/outwiker-1.8.0.ebuild
new file mode 100644
index 000000000000..a7610870a498
--- /dev/null
+++ b/x11-misc/outwiker/outwiker-1.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="The tree notes organizer"
+HOMEPAGE="http://jenyay.net/Outwiker/English"
+SRC_URI="https://github.com/Jenyay/${PN}/archive/stable_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pywebkitgtk[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils
+ x11-themes/hicolor-icon-theme
+"
+
+S="${WORKDIR}/${PN}-stable_${PV}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ # fix desktop file
+ sed -i -e 's/Application;//' outwiker.desktop || die 'sed on outwiker.desktop failed'
+
+ epatch_user
+}