summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-14 11:05:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 10:18:01 +0100
commit9f4d078cf2feeaab0e3fddad20192f5781a26380 (patch)
tree6fd47afafb51621a89edafa62fb1523e46ce8103 /x11-misc/pcmanfm/pcmanfm-1.3.2.ebuild
parentx11-libs/libfm: 1.3.2 version bump, switch to GTK3, fix xdg (diff)
downloadgentoo-9f4d078cf2feeaab0e3fddad20192f5781a26380.tar.gz
gentoo-9f4d078cf2feeaab0e3fddad20192f5781a26380.tar.bz2
gentoo-9f4d078cf2feeaab0e3fddad20192f5781a26380.zip
x11-misc/pcmanfm: 1.3.2 version bump, switch to GTK3
Bug: https://bugs.gentoo.org/691328 Closes: https://bugs.gentoo.org/771834 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/pcmanfm/pcmanfm-1.3.2.ebuild')
-rw-r--r--x11-misc/pcmanfm/pcmanfm-1.3.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/pcmanfm/pcmanfm-1.3.2.ebuild b/x11-misc/pcmanfm/pcmanfm-1.3.2.ebuild
new file mode 100644
index 000000000000..a57bad0e46c0
--- /dev/null
+++ b/x11-misc/pcmanfm/pcmanfm-1.3.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-${PV/_/}"
+inherit xdg readme.gentoo-r1
+
+DESCRIPTION="Fast lightweight tabbed filemanager"
+HOMEPAGE="https://wiki.lxde.org/en/PCManFM"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.18:2
+ >=lxde-base/menu-cache-1.1.0-r1
+ virtual/eject
+ virtual/freedesktop-icon-theme
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ >=x11-libs/libfm-${PV}:=[gtk]
+ x11-libs/libX11
+ x11-libs/pango
+ x11-misc/shared-mime-info
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc \
+ --with-gtk=3 \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ local DOC_CONTENTS="PCmanFM can optionally support the menu://applications/
+ location. You should install lxde-base/lxmenu-data for that functionality."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}