summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 00:26:05 +0000
committerSam James <sam@gentoo.org>2021-01-02 00:26:05 +0000
commit077297f442e9c6d3bc3c3f29476d1f2574258042 (patch)
tree0ace48a208c0935ed660609678f66f82d0644fbc /x11-misc/picom/picom-8.2-r1.ebuild
parentmedia-libs/bcg729: remove live ebuild (diff)
downloadgentoo-077297f442e9c6d3bc3c3f29476d1f2574258042.tar.gz
gentoo-077297f442e9c6d3bc3c3f29476d1f2574258042.tar.bz2
gentoo-077297f442e9c6d3bc3c3f29476d1f2574258042.zip
x11-misc/picom: revbump for libconfig subslot dep
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/picom/picom-8.2-r1.ebuild')
-rw-r--r--x11-misc/picom/picom-8.2-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/picom/picom-8.2-r1.ebuild b/x11-misc/picom/picom-8.2-r1.ebuild
new file mode 100644
index 000000000000..ff52bddb5e7d
--- /dev/null
+++ b/x11-misc/picom/picom-8.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="
+ dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig:=
+ dev-libs/libxdg-basedir
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}