summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2020-05-07 00:28:29 -0400
committerBernard Cafarelli <voyageur@gentoo.org>2020-05-08 17:55:03 +0200
commit0dd49cf6155756878966801d0d0049a6f835ec2e (patch)
tree1e5e1dff59f73dafccbbd4b438b628a20f476336 /x11-misc/picom
parentnet-misc/youtube-dl: Version 2020.05.08 (diff)
downloadgentoo-0dd49cf6155756878966801d0d0049a6f835ec2e.tar.gz
gentoo-0dd49cf6155756878966801d0d0049a6f835ec2e.tar.bz2
gentoo-0dd49cf6155756878966801d0d0049a6f835ec2e.zip
x11-misc/picom: version bump to 8
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/15673 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc/picom')
-rw-r--r--x11-misc/picom/Manifest1
-rw-r--r--x11-misc/picom/picom-8.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/picom/Manifest b/x11-misc/picom/Manifest
index e6cd0927bea1..4d1db30768fb 100644
--- a/x11-misc/picom/Manifest
+++ b/x11-misc/picom/Manifest
@@ -1 +1,2 @@
DIST picom-7.5.tar.gz 219456 BLAKE2B 54113547b575ad6aa1329e92ae331b7d49207fdcdc6b49d31d8ab125f7335730a7e53b260c6a6c33d5350bec1e9e6357fd34023dc7837de165289446f8f492b8 SHA512 6535e5eab1a243bbee62448bc48830b7ea3566f94b2c45d9ca76fd8b8056e1f00e55f0e4b58110364d2c4f56652cc005622d644c1db1db41d2811ecc19e6d44a
+DIST picom-8.tar.gz 242059 BLAKE2B cfeec7f40eaa43c115bd326abeaa547553f7bdd22a2e6b2a96f46d87c164b0e9403a876f069077e3b85d11af685aadb0cff2a4e7df2cf87646f2552f9c1a01df SHA512 154dd42dea16aca463e7d7f9913a8f10740df892bfdda2fee210a94b13c8eaf6201b35e505daf45075fdb1980bb9b85adf170b649702c1b1e2fcdc1d88406b4a
diff --git a/x11-misc/picom/picom-8.ebuild b/x11-misc/picom/picom-8.ebuild
new file mode 100644
index 000000000000..b521266c63e2
--- /dev/null
+++ b/x11-misc/picom/picom-8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="
+ dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig
+ dev-libs/libxdg-basedir
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}