summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-03 14:58:01 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-03 14:58:01 +0100
commit2858743188078baaf16812de1e6bbb1121a21c93 (patch)
tree7694b80f591ebaa4aaa863801f13dd9572f1a133 /x11-misc/piedock/piedock-1.6.9.ebuild
parentsys-boot/refind: HOMEPAGE to use https. (diff)
downloadgentoo-2858743188078baaf16812de1e6bbb1121a21c93.tar.gz
gentoo-2858743188078baaf16812de1e6bbb1121a21c93.tar.bz2
gentoo-2858743188078baaf16812de1e6bbb1121a21c93.zip
x11-misc/piedock: Version 1.6.9 by pavel sanda (bug #643222).
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-misc/piedock/piedock-1.6.9.ebuild')
-rw-r--r--x11-misc/piedock/piedock-1.6.9.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/piedock/piedock-1.6.9.ebuild b/x11-misc/piedock/piedock-1.6.9.ebuild
new file mode 100644
index 000000000000..01ba6137e9ee
--- /dev/null
+++ b/x11-misc/piedock/piedock-1.6.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A little bit like the famous OS X dock but in shape of a pie menu"
+HOMEPAGE="
+ http://markusfisch.de/PieDock
+ https://github.com/markusfisch/PieDock
+"
+SRC_URI="
+ https://github.com/markusfisch/PieDock/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ media-libs/libpng:0=
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXrender
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="${RDEPEND}"
+DOCS=( res/${PN}rc.sample AUTHORS ChangeLog NEWS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-signals.patch
+)
+S=${WORKDIR}/PieDock-${PV}
+
+src_configure() {
+ econf \
+ $(use_enable gtk) \
+ --disable-kde \
+ --bindir="${EPREFIX}"/usr/bin \
+ --enable-xft \
+ --enable-xmu \
+ --enable-xrender
+}