summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKajzer <kajzersoze72@gmail.com>2018-05-04 12:59:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-04 23:05:07 +0200
commit6d597a32e22e77dc620678702aad9c14e44d2978 (patch)
tree8533a33f30710f8f8b0de086b994b140dd5f69d2 /x11-misc/polybar/polybar-3.1.0.ebuild
parentdev-lang/php: Fix building with freetype 2.9.1 by using pkgconfig (diff)
downloadgentoo-6d597a32e22e77dc620678702aad9c14e44d2978.tar.gz
gentoo-6d597a32e22e77dc620678702aad9c14e44d2978.tar.bz2
gentoo-6d597a32e22e77dc620678702aad9c14e44d2978.zip
x11-misc/polybar: new package.
Polybar is a fast and easy-to-use tool for creating status bars. Closes: https://github.com/gentoo/gentoo/pull/8244 Closes: https://bugs.gentoo.org/643286
Diffstat (limited to 'x11-misc/polybar/polybar-3.1.0.ebuild')
-rw-r--r--x11-misc/polybar/polybar-3.1.0.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/polybar/polybar-3.1.0.ebuild b/x11-misc/polybar/polybar-3.1.0.ebuild
new file mode 100644
index 000000000000..a04e956a0e9e
--- /dev/null
+++ b/x11-misc/polybar/polybar-3.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+XPP_VERSION="1.4.0"
+I3IPCPP_VERSION="0.7.1"
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/jaagr/polybar"
+SRC_URI="https://github.com/jaagr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/jaagr/xpp/archive/${XPP_VERSION}.tar.gz -> xpp-${XPP_VERSION}.tar.gz
+ https://github.com/jaagr/i3ipcpp/archive/v${I3IPCPP_VERSION}.tar.gz -> i3ipcpp-${I3IPCPP_VERSION}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa curl i3wm ipc mpd network"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ x11-base/xcb-proto
+ x11-libs/libxcb
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-image
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ i3wm? ( dev-libs/jsoncpp )
+ mpd? ( media-libs/libmpdclient )
+ network? ( net-wireless/wireless-tools )
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ rmdir "${S}"/lib/xpp || die
+ mv "${WORKDIR}"/xpp-$XPP_VERSION "${S}"/lib/xpp || die
+
+ rmdir "${S}"/lib/i3ipcpp || die
+ mv "${WORKDIR}"/i3ipcpp-$I3IPCPP_VERSION "${S}"/lib/i3ipcpp || die
+
+ sed -i "s/.*cpp_error,.*/&\n\t 'eventstruct' : lambda x, y: None,/" lib/xpp/generators/cpp_client.py || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_IPC_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ )
+ cmake-utils_src_configure
+}